Bug 860776 - Incorrect interpreter used in rhts-* scripts
Incorrect interpreter used in rhts-* scripts
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: beah (Show other bugs)
0.9
Unspecified Unspecified
low Severity medium (vote)
: 0.10.0
: ---
Assigned To: Dan Callaghan
Misc
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 12:57 EDT by Nikolai Kondrashov
Modified: 2018-02-05 19:41 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-18 01:59:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch fixing the problem. (3.28 KB, patch)
2012-09-26 12:57 EDT, Nikolai Kondrashov
no flags Details | Diff

  None (edit)
Description Nikolai Kondrashov 2012-09-26 12:57:39 EDT
Created attachment 617668 [details]
Patch fixing the problem.

Despite using bash'isms some rhts-* scripts use /bin/sh in the shebang line.
On systems, where /bin/sh is not bash these scripts fail to run because of syntax errors.

The attached patch fixes the problem.
Comment 1 Min Shin 2012-10-17 07:17:05 EDT
Does this need to be in a customer only hot-fix release along with 866507?
Comment 2 Nikolai Kondrashov 2012-10-17 07:22:44 EDT
This is not urgent from my point.
Comment 3 Dan Callaghan 2012-10-17 18:11:55 EDT
Right, this is not too serious since on all conventional RHEL and Fedora systems /bin/sh will be bash and the rhts scripts work fine in bash's POSIX mode as far as I know.
Comment 4 Dan Callaghan 2012-10-18 01:59:51 EDT
Fixed in rhts-4.52-3.
Comment 5 Raymond Mancy 2012-11-22 01:42:35 EST
This has now been released

Note You need to log in before you can comment on or make changes to this bug.