Bug 86079 - No fstab entry for Toshiba USB floppy; device is /dev/sda
Summary: No fstab entry for Toshiba USB floppy; device is /dev/sda
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-13 17:01 UTC by Toralf
Modified: 2014-03-17 02:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-29 20:55:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
updfstab.conf used as workaround (131 bytes, text/plain)
2003-04-01 14:24 UTC, Toralf
no flags Details

Description Toralf 2003-03-13 17:01:49 UTC
Description of problem:
We have some Toshiba laptops with USB floppy drives. These drives are identified
as "USB Mass Storage devices", and assigned to device file /dev/sda via SCSI
emulation. An entry for the unit is not added to /etc/fstab.

I want:

Drive assigned to /dev/fd0 and standard /dev/fd0 entry added to /etc/fstab

- or -

/dev/sda                /mnt/floppy             auto    noauto,users    0 0

automatically added to /etc/fstab.


Version-Release number of selected component (if applicable):
0.99.52

How reproducible:
Every time

Steps to Reproduce: Actual results: Expected results:
Well, it's obvious, isn't it?

Additional info:
Possibly related to bug 59068.

Comment 1 Bill Nottingham 2003-03-13 18:40:54 UTC
/dev/fd0 is impossible. They don't support the same floppy interface.
What does 'cat /proc/scsi/usb-storage-*/*' say?

Comment 2 Toralf 2003-03-13 18:48:28 UTC
   Host scsi0: usb-storage
       Vendor: TEAC    
      Product: TEAC FD-05PUB   
Serial Number: None
     Protocol: Uniform Floppy Interface (UFI)
    Transport: Control/Bulk/Interrupt
         GUID: 064400000000000000000000
     Attached: Yes


Comment 3 Toralf 2003-04-01 14:24:38 UTC
Created attachment 90811 [details]
updfstab.conf used as workaround

I'm currently using this updfstab.conf to enable support for the drive, and
antother interesting unit, too.

This should probably be in the default, though. And maybe 
    match   floppy "TEAC FD"
would be even better (?) (This device + possibly other unsupported units would
be detected.)

Comment 4 Toralf 2003-04-01 14:36:22 UTC
Messed up the comment a bit again ;-/ What I meant to suggest in the last note,
was that just "FD" might be used instead of "TEAC FD" in the match string.

Comment 5 Tim Waugh 2004-02-25 11:55:52 UTC
I think this might have been fixed since 0.99.96.  Have you tried
Fedora Core 1?

Comment 6 Toralf 2004-04-07 09:44:16 UTC
The "floppy" entry in Fedora Core 1 /etc/updfstab.conf.default looks
promising, but I still haven't been able to test it...

Comment 7 Bill Nottingham 2005-03-29 20:55:32 UTC
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

Assuming fixed in the current trees (note that HAL and fstab-sync handles this now.)


Note You need to log in before you can comment on or make changes to this bug.