Bug 860842 - st reservation conflicts [NEEDINFO]
st reservation conflicts
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.8
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 16:42 EDT by ThinkTank
Modified: 2015-01-06 08:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:16:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (yeddur)


Attachments (Terms of Use)

  None (edit)
Description ThinkTank 2012-09-26 16:42:19 EDT
Description of problem:
This is specific to HP C Class blade systems. As soon as we create and enable a SAN fabric zone using 2 blades servers within the same HP blade chasis to tape drivers, we get -

 kernel: st 2:0:1:0: reservation conflict


Version-Release number of selected component (if applicable):

Linux Serverxxxx 2.6.18-308.1.1.el5 #1 SMP Fri Feb 17 16:51:01 EST 2012 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:
Hardware/OS used: HP BL685c G7s in a HP flexfabric C7000 chassis on RH5U8 (OS).
San switch - Brocade 5300 ( 8GB)

Steps to Reproduce:
1. Zone a blade server in the HP blade chasis to a tape drive.
2. Zone a second blade server in the same HP blade chasis to the tape drive.
3. As soon as zone is enabled, we start seeing scsi reservation conflicts messages in the /var/log/messages file. This continues till the 2nd blade server is removed from the zoning.

Every 20 minutes , we see the following messages in the messages file.

Jun 12 10:46:49 srv1 kernel: st 2:0:1:0: reservation conflict
Jun 12 10:46:49 srv1 kernel: st1: Error 110018 (sugg. bt 0x0, driver bt 0x0, host bt 0x11).
Jun 12 10:46:49 srv1 kernel: st 2:0:4:0: reservation conflict
Jun 12 10:46:49 srv1 kernel: st4: Error 110018 (sugg. bt 0x0, driver bt 0x0, host bt 0x11).
Jun 12 10:46:49 srv1 kernel: st 2:0:6:0: reservation conflict
Jun 12 10:46:49 srv1 kernel: st6: Error 110018 (sugg. bt 0x0, driver bt 0x0, host bt 0x11).
Jun 12 10:55:18 srv1 ntpd[10669]: synchronized to 172.20.5.42, stratum 3
Jun 12 11:06:50 srv1 kernel: st 2:0:1:0: reservation conflict
Jun 12 11:06:50 srv1 kernel: st1: Error 110018 (sugg. bt 0x0, driver bt 0x0, host bt 0x11).
Jun 12 11:06:50 srv1 kernel: st 2:0:2:0: reservation conflict
Jun 12 11:06:50 srv1 kernel: st2: Error 110018 (sugg. bt 0x0, driver bt 0x0, host bt 0x11).
Jun 12 11:06:50 srv1 kernel: st 2:0:3:0: reservation conflict
Jun 12 11:06:50 srv1 kernel: st3: Error 110018 (sugg. bt 0x0, driver bt 0x0, host bt 0x11).
Jun 12 11:06:50 srv1 kernel: st 2:0:4:0: reservation conflict
Jun 12 11:06:50 srv1 kernel: st4: Error 110018 (sugg. bt 0x0, driver bt 0x0, host bt 0x11).
Jun 12 11:06:50 srv1 kernel: st 2:0:5:0: reservation conflict
Jun 12 11:06:50 srv1 kernel: st5: Error 110018 (sugg. bt 0x0, driver bt 0x0, host bt 0x11).
Jun 12 11:06:50 srv1 kernel: st 2:0:9:0: reservation conflict
Jun 12 11:06:50 srv1 kernel: st9: Error 110018 (sugg. bt 0x0, driver bt 0x0, host bt 0x11).
Jun 12 11:13:22 xxx ntpd[10669]: synchronized to 172.20.5.41, stratum 3
Jun 12 11:26:50 srv1 kernel: st 2:0:9:0: reservation conflict
Jun 12 11:26:50 srv1 kernel: st9: Error 110018 (sugg. bt 0x0, driver bt 0x0, host bt 0x11).
Actual results:


Expected results:


Additional info:
This issue is only isolated in our case to the HP C class blade systems.
Comment 1 RHEL Product and Program Management 2014-03-07 08:41:34 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 2 RHEL Product and Program Management 2014-06-02 09:16:03 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.