This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 860871 - Non-useful/incomplete error output if <revision> tag is left out of Revision_History.xml
Non-useful/incomplete error output if <revision> tag is left out of Revision_...
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 20:37 EDT by Misha H. Ali
Modified: 2012-11-06 21:25 EST (History)
2 users (show)

See Also:
Fixed In Version: 3.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 21:25:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Misha H. Ali 2012-09-26 20:37:17 EDT
Description of problem:

If the opening <revision> tag for a revision in the Revision_History.xml file is omitted, the result of a publican build command is an incomplete mismatched tag error. This may be intentional, but it is not helpful towards discovering the reason.

Version-Release number of selected component (if applicable):

3.0

How reproducible:

100%

Steps to Reproduce:
1. In a working publican book, edit the Revision_History.xml file.
2. Remove or comment out the most recent revision's opening <revision> tag.
3. Run a publican build command with en-US as the language and html-single as the format.
  
Actual results:

mismatched tag at line 24, column 11, byte 851 at /usr/lib64/perl5/vendor_perl/XML/Parser.pm line 187

(this is the entirety of the output after the build command is run)

Expected results:

Some information about which file failed the build or a more useful error message in general.
Comment 1 Ruediger Landmann 2012-09-26 20:48:55 EDT
(In reply to comment #0)
> Description of problem:
> 
> If the opening <revision> tag for a revision in the Revision_History.xml
> file is omitted, the result of a publican build command is an incomplete
> mismatched tag error. This may be intentional, but it is not helpful towards
> discovering the reason.

Hi Misha; this is probably a dupe of Bug 846812 -- if so, this behaviour was fixed prior to build publican-3.0-0.fc17.t219.noarch

You don't say precisely which build you've got on your system; can you please include the output of:

rpm -q publican

so we can tell if this is a new issue or not?

Cheers
Rudi
Comment 2 Misha H. Ali 2012-09-26 20:55:36 EDT
The output for rpm -q publican is:

publican-3.0-0.fc17.t216.noarch

Apologies if this is already resolved, I encountered it yesterday and thought it should be reported.

Note You need to log in before you can comment on or make changes to this bug.