Bug 860879 - sssd-1.8.4-13.fc16.i686 is missing /etc/sssd/sssd.conf
sssd-1.8.4-13.fc16.i686 is missing /etc/sssd/sssd.conf
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: sssd (Show other bugs)
16
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Jakub Hrozek
Fedora Extras Quality Assurance
:
: 860873 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 21:21 EDT by Wayne Pollock
Modified: 2012-09-27 04:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-27 04:34:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wayne Pollock 2012-09-26 21:21:18 EDT
Description of problem:

The package lists /etc/sssd/sssd.conf as one of the files it will install, but no such file is installed.  rpm -qV sssd doesn't show any issues.

Version-Release number of selected component (if applicable):

sssd-1.8.4-13.fc16.i686

How reproducible:

Always

Steps to Reproduce:
1.  yum install sssd
2.  rpm -ql sssd | grep sssd/sssd.conf
3.  ls -la /etc/sssd/
  
Actual results:
2. /etc/sssd/sssd.conf
3.
total 16
drwx------.   2 root root  4096 Jun 13 19:37 ./
drwxr-xr-x. 184 root root 12288 Sep 26 03:35 ../

Expected results:
2. /etc/sssd/sssd.conf
3.
total 16
drwx------.   2 root root  4096 Jun 13 19:37 ./
drwxr-xr-x. 184 root root 12288 Sep 26 03:35 ../
-rw-------. ??? root root ????? ???????????? sssd.conf


Additional info:

I tried a yumdownloader , then rpm2cpio sssd*rpm > sssd.cpio, and then
cpio -itv < sssd.cpio | grep sssd.conf.  the file isn't there.  It surprises me that rpm -ql shows the file anyway, or that rpm -qV doesn't consider the missing file as a problem.  So either the package's SPEC file is wrong, or the file is missing.  I'm guessing from other reports that previous versions of the package included the file, so I think it is missing.

(There is an example sssd.conf file in /usr/share/doc/sssd-version.)
Comment 1 Jakub Hrozek 2012-09-27 04:29:23 EDT
*** Bug 860873 has been marked as a duplicate of this bug. ***
Comment 2 Jakub Hrozek 2012-09-27 04:34:36 EDT
This is on purpose.

The file is marked in the specfile as %ghost which means that the file is owned by the package even though it doesn't in fact exist.

Please either modify the example config file in the docs directory or use a tool such as as authconfig{,-gtk} to configure the SSSD.

Note You need to log in before you can comment on or make changes to this bug.