Bug 860898 - [abrt] gimp-2.8.2-1.fc17: Process /usr/bin/gimp-2.8 was killed by signal 11 (SIGSEGV)
[abrt] gimp-2.8.2-1.fc17: Process /usr/bin/gimp-2.8 was killed by signal 11 (...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
17
All Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
abrt_hash:51c6c89cba8e9da560594028a8e...
:
: 846537 951818 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 23:42 EDT by ud.connexus
Modified: 2013-08-01 00:22 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 00:22:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (2.44 KB, text/plain)
2012-09-26 23:42 EDT, ud.connexus
no flags Details
File: environ (1.48 KB, text/plain)
2012-09-26 23:43 EDT, ud.connexus
no flags Details
File: backtrace (30.43 KB, text/plain)
2012-09-26 23:43 EDT, ud.connexus
no flags Details
File: limits (1.29 KB, text/plain)
2012-09-26 23:43 EDT, ud.connexus
no flags Details
File: cgroup (129 bytes, text/plain)
2012-09-26 23:43 EDT, ud.connexus
no flags Details
File: maps (34.79 KB, text/plain)
2012-09-26 23:43 EDT, ud.connexus
no flags Details
File: dso_list (9.79 KB, text/plain)
2012-09-26 23:43 EDT, ud.connexus
no flags Details
File: var_log_messages (573 bytes, text/plain)
2012-09-26 23:43 EDT, ud.connexus
no flags Details
File: open_fds (708 bytes, text/plain)
2012-09-26 23:43 EDT, ud.connexus
no flags Details
tp_reproduce_video (1.46 MB, application/octet-stream)
2012-11-08 14:49 EST, Gilles Dufour
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 683983 None None None Never

  None (edit)
Description ud.connexus 2012-09-26 23:42:55 EDT
Description of problem:
After inserting text or removing text, gimp just crash.

Version-Release number of selected component:
gimp-2.8.2-1.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
backtrace_rating: 4
cmdline:        gimp-2.8
crash_function: _gail_text_view_delete_range_cb
kernel:         3.5.4-1.fc17.i686.PAE

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 _gail_text_view_delete_range_cb at gailtextview.c
: #1 _gtk_marshal_VOID__BOXED_BOXED at gtkmarshalers.c
: #6 gtk_text_buffer_emit_delete at gtktextbuffer.c
: #7 gtk_text_buffer_delete at gtktextbuffer.c
: #8 gtk_text_buffer_set_text at gtktextbuffer.c
: #9 gimp_text_buffer_set_text at gimptextbuffer.c
: #10 gimp_text_tool_connect at gimptexttool.c
: #11 gimp_text_tool_set_drawable at gimptexttool.c
: #12 gimp_text_tool_control at gimptexttool.c
: #13 gimp_tool_control at gimptool.c
Comment 1 ud.connexus 2012-09-26 23:42:58 EDT
Created attachment 617874 [details]
File: core_backtrace
Comment 2 ud.connexus 2012-09-26 23:43:00 EDT
Created attachment 617875 [details]
File: environ
Comment 3 ud.connexus 2012-09-26 23:43:03 EDT
Created attachment 617876 [details]
File: backtrace
Comment 4 ud.connexus 2012-09-26 23:43:06 EDT
Created attachment 617877 [details]
File: limits
Comment 5 ud.connexus 2012-09-26 23:43:08 EDT
Created attachment 617878 [details]
File: cgroup
Comment 6 ud.connexus 2012-09-26 23:43:12 EDT
Created attachment 617879 [details]
File: maps
Comment 7 ud.connexus 2012-09-26 23:43:14 EDT
Created attachment 617880 [details]
File: dso_list
Comment 8 ud.connexus 2012-09-26 23:43:18 EDT
Created attachment 617881 [details]
File: var_log_messages
Comment 9 ud.connexus 2012-09-26 23:43:20 EDT
Created attachment 617882 [details]
File: open_fds
Comment 10 Nils Philippsen 2012-11-06 06:11:59 EST
Hi. I couldn't reproduce the problem you described, I tried it on F-17, both on x86_64 and i686:

0) Start GIMP
1) Create a new image (640x400 px)
2) Choose the text tool
3) Click somewhere in the image
4) Write some text
5) Select some letters of text in a terminal window (Shift+Ctrl+C)
6) Position text cursor in the middle of the written text, paste (Ctrl+V)
7) Click-drag to select some letters, backspace to delete it
8) Click-drag to select some letters, Ctrl+X to cut/delete

Can you reproduce this problem still? If yes, please describe how (and what differs from the way I tried it). Thanks!
Comment 11 Gilles Dufour 2012-11-06 10:57:31 EST
Yes I can still reproduce.
You need to select "Use editor" with gnome.
The workaround is actually to not use the gnome editor.

Gilles.
Comment 12 Nils Philippsen 2012-11-06 11:38:31 EST
Using the external editor doesn't make a difference here -- no crash.

Can you create a screen capture/video and attach it here? It seems that you use GNOME Shell, to create a screencap video in it just press Ctrl+Alt+Shift+R to start recording, then do what you did to make GIMP crash, then press the same key combination to stop recording. This will place a video file in $HOME/Videos which you can attach here. Thanks!
Comment 13 Gilles Dufour 2012-11-08 14:49:23 EST
Created attachment 641056 [details]
tp_reproduce_video

Desktop video capture to show how to reproduce the problem
Comment 14 Nils Philippsen 2012-11-13 11:31:15 EST
Thanks! I can't spot anything out of the ordinary regarding your setup in the video. I've also tried to reproduce this as you demonstrated, both closing the external editor before clicking the move tool, and leaving it open, to no avail. Additionally I tried this with a test user (i.e. should be a clean environment), also no success in getting GIMP to crash -- let's check at the opposite:

Please move away (don't delete!) all GIMP configuration directories (i.e. $HOME/.gimp-2.8 but also all other versions -- $HOME/.gimp-* -- GIMP tries to migrate settings if they exist and I want to avoid that), then try to reproduce your problem.
Comment 15 Nils Philippsen 2013-04-17 05:52:10 EDT
*** Bug 846537 has been marked as a duplicate of this bug. ***
Comment 16 Nils Philippsen 2013-04-17 05:58:51 EDT
*** Bug 951818 has been marked as a duplicate of this bug. ***
Comment 17 Nils Philippsen 2013-04-17 06:02:28 EDT
Can anybody subscribed to this bug reproduce the issue with a "clean slate" as I described in comment #14? I.e. move away (don't delete, but e.g. move to a subfolder) all .gimp-* folders in your home directory, then run GIMP and try to reproduce the issue. Thanks!
Comment 18 Nils Philippsen 2013-05-27 11:41:24 EDT
This bug is fixed upstream in gtk-2-24:

commit ba5ac33cdc18fe252de9baac6a2927f9ea77e6ab
Author: Michael Natterer <mitch@gimp.org>
Date:   Sun Apr 21 05:09:52 2013 +0200

    entry: unset the completion in dispose() not finalize()

    Most likely fixes whatever evil gail interaction causing a crash I
    could never reproduce but has been reported several times against GIMP.
    The same fix is in GTK+ 3.x already (bug #683983).

 gtk/gtkentry.c |    3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)
Comment 19 Fedora End Of Life 2013-07-03 20:32:58 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 20 Fedora End Of Life 2013-08-01 00:22:40 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.