Bug 860930 - [US2597][fork] The new --[no]-git, --[no]-dns options is not shown in help and man page
[US2597][fork] The new --[no]-git, --[no]-dns options is not shown in help a...
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 02:26 EDT by Rony Gong
Modified: 2015-05-14 22:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-04 11:10:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rony Gong 2012-09-27 02:26:40 EDT
Description of problem:
Since the options has been updated, so need show it in the help

Version-Release number of selected component (if applicable):
fork_ami_US2597_US2599_US2813_US2817_US2872_172

How reproducible:
always 

Steps to Reproduce:
1.ssh into the instance type: rhc app --help   or  man rhc-app
2.

  
Actual results:
Show like:
  -n|--nogit                     Only create remote space, don't pull it locally
  --no-dns                       Skip DNS check. Must be used in combination with --nogit



Expected results:
Show new options:
option ["--[no-]git"], "Only create remote space, don't pull it locally"
    option ["--nogit"], "DEPRECATED! Only create remote space, don't pull it locally", :deprecated => {:arg => :git, :val => false}
    option ["--[no-]dns"], "Skip DNS check. Must be used in combination with --no-git"
    option ["--nodns"], "DEPRECATED! Skip DNS check. Must be used in combination with --no-git", :deprecated => {:arg => :dns, :val => false}
    option ["--enable-jenkins [server_name]"], "Indicates to create a Jenkins application (if not already available) and embed the Jenkins client into this application. The default name will be 'jenkins' if not specified. Note that --no-dns is ignored for the creation of the Jenkins application."
    argument :name, "The name you wish to give your application", ["-a", "--app name"]


Additional info:
Comment 1 Rony Gong 2012-09-27 02:31:28 EDT
rhc app create --help
Usage: rhc app create <name> <cartridge> [... <other cartridges>][--namespace namespace]

Create an application and adds it to a domain

Options for app create
  -n, --namespace namespace Namespace to add your application to
  -g, --gear-size size      The  size  of the gear for this app. Available gear sizes depend on the type of account you have.
  -s, --scaling             Enable scaling for this application
  -r, --repo dir            Git Repo path (defaults to ./$app_name) (applicable to the  create command)
  --[no-]git                Only  create  remote space, don't pull it locally
  --nogit                   DEPRECATED! Only  create  remote space, don't pull it locally
  --[no-]dns                Skip DNS check. Must be used in combination with --no-git
  --enable-jenkins [server_name] Indicates to create a Jenkins application (if not already available)  and  embed the Jenkins client into this application. The default name will be 'jenkins' if not specified. Note that --no-dns is
ignored for the creation of the Jenkins application.
  -a, --app name            The name you wish to give your application
  -t, --type cartridge      The first cartridge added to the application. Usually a web framework

seems here lost --nodns option?
Comment 2 Rony Gong 2012-09-27 04:09:47 EDT
more to comment1:
maybe be lost one line:
--nodns  "DEPRECATED! Skip DNS check. Must be used in combination with --no-dns"
Comment 3 John (J5) Palmieri 2012-10-04 11:10:26 EDT
there is no --nodns command.  In the old versions --no-dns was correct but --nogit was not so we deprecated --nogit and added --no-git

rhc app help should not show --no-git or --no-dns because that is an option on rhc app create

Man page is in fork though we should fix it up to separate out all the commands next sprint

Note You need to log in before you can comment on or make changes to this bug.