Bug 860931 - [US2597][fork]Show exception when create application in ruby-1.8 env
[US2597][fork]Show exception when create application in ruby-1.8 env
Status: CLOSED DUPLICATE of bug 860954
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 02:31 EDT by Rony Gong
Modified: 2015-05-14 22:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-28 12:38:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rony Gong 2012-09-27 02:31:32 EDT
Description of problem:
The exception only happened in ruby-1.8 env platform. Although show exepction, the app still created and can work well.


Version-Release number of selected component (if applicable):
fork_ami_US2597_US2599_US2813_US2817_US2872_172

How reproducible:
always


Steps to Reproduce:
1.rhc app create q3jboss -t jbossas-7
2.
3.
  
Actual results:
[qgong@localhost dev]$ rhc app create q3jboss -t jbossas-7 
Password: 

Creating application 'q3jboss'
==============================

  Gear Size: default
  Cartridge: jbossas-7
  Scaling:   no
  Namespace: qgong

Your application's domain name is being propagated worldwide (this might take a minute)...
Initialized empty Git repository in /home/qgong/mytest/dev/q3jboss/.git/
/usr/lib/ruby/gems/1.8/gems/rhc-0.99.3/lib/rhc/git_helper.rb:41:in `git_clone_repo': undefined method `value' for nil:NilClass (NoMethodError)
	from /usr/lib/ruby/1.8/open3.rb:86:in `popen3'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.99.3/lib/rhc/git_helper.rb:37:in `git_clone_repo'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.99.3/lib/rhc/helpers.rb:216:in `call'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.99.3/lib/rhc/helpers.rb:216:in `section'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.99.3/lib/rhc/helpers.rb:233:in `paragraph'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.99.3/lib/rhc/git_helper.rb:36:in `git_clone_repo'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.99.3/lib/rhc/commands/app.rb:312:in `run_git_clone'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.99.3/lib/rhc/commands/app.rb:83:in `create'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.99.3/lib/rhc/commands.rb:103:in `send'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.99.3/lib/rhc/commands.rb:103:in `to_commander'
	from /usr/lib/ruby/gems/1.8/gems/commander-4.1.2/lib/commander/command.rb:180:in `call'
	from /usr/lib/ruby/gems/1.8/gems/commander-4.1.2/lib/commander/command.rb:180:in `call'
	from /usr/lib/ruby/gems/1.8/gems/commander-4.1.2/lib/commander/command.rb:155:in `run'
	from /usr/lib/ruby/gems/1.8/gems/commander-4.1.2/lib/commander/runner.rb:402:in `run_active_command'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.99.3/lib/rhc/command_runner.rb:55:in `run!'
	from /usr/lib/ruby/gems/1.8/gems/commander-4.1.2/lib/commander/delegates.rb:7:in `run!'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.99.3/lib/rhc/cli.rb:40:in `start'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.99.3/bin/rhc:57
	from /usr/bin/rhc:19:in `load'
	from /usr/bin/rhc:19



Expected results:
shouldn't show any exception.

Additional info:
Comment 1 John (J5) Palmieri 2012-09-28 12:38:36 EDT

*** This bug has been marked as a duplicate of bug 860954 ***

Note You need to log in before you can comment on or make changes to this bug.