Bug 860979 - [US2597][fork]Show exception when create application with this option combination " -t $type --no-dns --enable-jenkins"
[US2597][fork]Show exception when create application with this option combina...
Status: CLOSED DUPLICATE of bug 860954
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 05:04 EDT by Rony Gong
Modified: 2015-05-14 22:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-28 12:37:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rony Gong 2012-09-27 05:04:39 EDT
Description of problem:
When run: rhc app create qnode -t nodejs-0.6 --no-dns --enable-jenkins
show exception.

But if just remove -t option, show the warning message, like:
[root@F17x64-openshift rhc]# rhc app create q2node  nodejs-0.6 --no-dns --enable-jenkins
Password: 

Creating application 'q2node'
=============================

  Namespace: qgong
  Cartridge: nodejs-0.6
  Gear Size: default
  Scaling:   no

The --no-dns option can't be used in conjunction with --enable-jenkins when creating an application.  Either remove the --no-dns option or first install your application with --no-dns and then use 'rhc cartridge add' to embed the
Jenkins client.



Version-Release number of selected component (if applicable):
fork_ami_US2597_US2599_US2813_US2817_US2872_172

How reproducible:
always

Steps to Reproduce:
1.rhc app create qnode -t nodejs-0.6 --no-dns --enable-jenkins
2.
3.
  
Actual results:
[root@F17x64-openshift rhc]# rhc app create qnode -t nodejs-0.6 --no-dns --enable-jenkins
Password: 

Creating application 'qnode'
============================

  Namespace: qgong
  Cartridge: nodejs-0.6
  Gear Size: default
  Scaling:   no

/usr/local/share/gems/gems/rhc-0.99.3/lib/rhc/commands/app.rb:336:in `check_jenkins': The --no-dns option can't be used in conjunction with --enable-jenkins when creating an application.  Either remove the --no-dns option or first install your application with --no-dns and then use 'rhc cartridge add' to embed the Jenkins client. (ArgumentError)
	from /usr/local/share/gems/gems/rhc-0.99.3/lib/rhc/commands/app.rb:45:in `create'
	from /usr/local/share/gems/gems/rhc-0.99.3/lib/rhc/commands.rb:103:in `block (3 levels) in to_commander'
	from /usr/local/share/gems/gems/commander-4.1.2/lib/commander/command.rb:180:in `call'
	from /usr/local/share/gems/gems/commander-4.1.2/lib/commander/command.rb:180:in `call'
	from /usr/local/share/gems/gems/commander-4.1.2/lib/commander/command.rb:155:in `run'
	from /usr/local/share/gems/gems/commander-4.1.2/lib/commander/runner.rb:402:in `run_active_command'
	from /usr/local/share/gems/gems/rhc-0.99.3/lib/rhc/command_runner.rb:55:in `run!'
	from /usr/local/share/gems/gems/commander-4.1.2/lib/commander/delegates.rb:11:in `run!'
	from /usr/local/share/gems/gems/rhc-0.99.3/lib/rhc/cli.rb:40:in `start'
	from /usr/local/share/gems/gems/rhc-0.99.3/bin/rhc:57:in `<top (required)>'
	from /usr/local/bin/rhc:23:in `load'
	from /usr/local/bin/rhc:23:in `<main>'

Expected results:
show error prompt message:
The --no-dns option can't be used in conjunction with --enable-jenkins when creating an application.  Either remove the --no-dns option or first install your application with --no-dns and then use 'rhc cartridge add' to embed the
Jenkins client.


Additional info:
Comment 1 John (J5) Palmieri 2012-09-27 19:06:40 EDT
I think this is now fixed.  -t used to also correspond to --trace which would print out stack traces.  Now we only accept --trace for stack traces.
Comment 2 Rony Gong 2012-09-27 22:46:24 EDT
restest it on my ruby-1.8 env, in fork_ami_US2597_US2599_US2813_US2817_US2872_173
[qgong@localhost rhc]$ rhc app create qnode -t nodejs-0.6 --no-dns --enable-jenkins
/usr/lib/ruby/1.8/optparse.rb:1448:in `complete': ambiguous option: -t (OptionParser::AmbiguousOption)
	from /usr/lib/ruby/1.8/optparse.rb:1287:in `parse_in_order'
	from /usr/lib/ruby/1.8/optparse.rb:1254:in `catch'
	from /usr/lib/ruby/1.8/optparse.rb:1254:in `parse_in_order'
	from /usr/lib/ruby/1.8/optparse.rb:1248:in `order!'
	from /usr/lib/ruby/1.8/optparse.rb:1339:in `permute!'
	from /usr/lib/ruby/1.8/optparse.rb:1360:in `parse!'
	from /usr/lib/ruby/gems/1.8/gems/commander-4.1.2/lib/commander/runner.rb:337:in `parse_global_options'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.99.3/lib/rhc/command_runner.rb:29:in `run!'
	from /usr/lib/ruby/gems/1.8/gems/commander-4.1.2/lib/commander/delegates.rb:7:in `run!'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.99.3/lib/rhc/cli.rb:40:in `start'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.99.3/bin/rhc:21
	from /usr/bin/rhc:19:in `load'
	from /usr/bin/rhc:19
Comment 3 John (J5) Palmieri 2012-09-28 12:37:34 EDT

*** This bug has been marked as a duplicate of bug 860954 ***

Note You need to log in before you can comment on or make changes to this bug.