Bug 860996 - [US2816][fork] Error "undefined method sshkeys" is shown when creating app
[US2816][fork] Error "undefined method sshkeys" is shown when creating app
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 05:31 EDT by joycezhang
Modified: 2015-05-14 22:05 EDT (History)
5 users (show)

See Also:
Fixed In Version: fork_ami_US2597_US2599_US2813_US2817_US2872_US2816_US2814_194
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:48:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description joycezhang 2012-09-27 05:31:24 EDT
Description of problem:
Error "undefined method sshkeys" is shown when creating app, please refer to following error details:
# rhc app create ruby19 -t ruby-1.9 -p xx
Creating application 'ruby19'
=============================

  Gear Size: default
  Cartridge: ruby-1.9
  Namespace: joycedev3
  Scaling:   no

Your application's domain name is being propagated worldwide (this might take a minute)...
/var/lib/gems/1.8/gems/rhc-0.99.2/lib/rhc/wizard.rb:141:in `ssh_key_uploaded?': undefined method `sshkeys' for nil:NilClass (NoMethodError)
	from /var/lib/gems/1.8/gems/rhc-0.99.2/lib/rhc/wizard.rb:214:in `upload_ssh_key_stage'
	from /var/lib/gems/1.8/gems/rhc-0.99.2/lib/rhc/wizard.rb:48:in `send'
	from /var/lib/gems/1.8/gems/rhc-0.99.2/lib/rhc/wizard.rb:48:in `run'
	from /var/lib/gems/1.8/gems/rhc-0.99.2/lib/rhc/wizard.rb:46:in `each'
	from /var/lib/gems/1.8/gems/rhc-0.99.2/lib/rhc/wizard.rb:46:in `run'
	from /var/lib/gems/1.8/gems/rhc-0.99.2/lib/rhc/commands/app.rb:285:in `check_sshkeys!'
	from /var/lib/gems/1.8/gems/rhc-0.99.2/lib/rhc/commands/app.rb:291:in `run_git_clone'
	from /var/lib/gems/1.8/gems/rhc-0.99.2/lib/rhc/commands/app.rb:83:in `create'
	from /var/lib/gems/1.8/gems/rhc-0.99.2/lib/rhc/commands.rb:99:in `send'
	from /var/lib/gems/1.8/gems/rhc-0.99.2/lib/rhc/commands.rb:99:in `to_commander'
	from /var/lib/gems/1.8/gems/commander-4.1.2/lib/commander/command.rb:180:in `call'
	from /var/lib/gems/1.8/gems/commander-4.1.2/lib/commander/command.rb:180:in `call'
	from /var/lib/gems/1.8/gems/commander-4.1.2/lib/commander/command.rb:155:in `run'
	from /var/lib/gems/1.8/gems/commander-4.1.2/lib/commander/runner.rb:402:in `run_active_command'
	from /var/lib/gems/1.8/gems/rhc-0.99.2/lib/rhc/command_runner.rb:55:in `run!'
	from /var/lib/gems/1.8/gems/commander-4.1.2/lib/commander/delegates.rb:7:in `run!'
	from /var/lib/gems/1.8/gems/rhc-0.99.2/lib/rhc/cli.rb:40:in `start'
	from /var/lib/gems/1.8/gems/rhc-0.99.2/bin/rhc:57
	from /usr/local/bin/rhc:19:in `load'
	from /usr/local/bin/rhc:19


Version-Release number of selected component (if applicable):
fork_ami_openshift_US2814_US22816_160

How reproducible:
always

Steps to Reproduce:
1. Create an app
# rhc app create ruby19 -t ruby-1.9 -p xxx
  
Actual results:
Error is shown as pasted in description.

Expected results:
App is created successfully without error shown.


Additional info:
1. This error is reproduced for all types app.
2. App can work fine in this case.
Comment 1 Xiaoli Tian 2012-09-28 08:31:29 EDT
Although this is not related to US2186, but using the repo for US2186 can not create app successfully
Comment 2 John (J5) Palmieri 2012-09-28 18:28:43 EDT
I'm not currently seeing this so please verify with latest ami
Comment 3 Xiaoli Tian 2012-09-28 21:51:29 EDT
(In reply to comment #2)
> I'm not currently seeing this so please verify with latest ami

Hi, John

This bug happened on fork_ami_openshift_US2814_US22816, not happened on  fork_ami_US2597_US2599_US2813_US2817_US2872, and this pull request https://github.com/J5/rhc/pull/12 has not merged in your repo, so not sure if it will happen again after it's merged.

Thanks
Comment 4 Wei Sun 2012-09-29 03:02:57 EDT
Move this bug to ASSIGNED,because test this bug on the latest fork_ami(fork_ami_US2597_US2599_US2813_US2817_US2872_186 (ami-19f04d70)),build rhc package using repo git@github.com:calfonso/rhc.git,this bug can be reproduced.

server:fork_ami_US2597_US2599_US2813_US2817_US2872_186 (ami-19f04d70)
client:building  rhc package using repo git@github.com:calfonso/rhc.git

step:
1.create an application

Result:
[sunwei@dhcp-8-229 dev]$ rhc app create php1 php-5.3
Password: ******

Creating application 'php1'
===========================

  Namespace: wsunfork929
  Cartridge: php-5.3
  Gear Size: default
  Scaling:   no

Your application's domain name is being propagated worldwide (this might take a minute)...
/home/sunwei/.gem/ruby/1.9.1/gems/rhc-0.99.3/lib/rhc/wizard.rb:141:in `ssh_key_uploaded?': undefined method `sshkeys' for nil:NilClass (NoMethodError)
	from /home/sunwei/.gem/ruby/1.9.1/gems/rhc-0.99.3/lib/rhc/wizard.rb:214:in `upload_ssh_key_stage'
	from /home/sunwei/.gem/ruby/1.9.1/gems/rhc-0.99.3/lib/rhc/wizard.rb:48:in `block in run'
	from /home/sunwei/.gem/ruby/1.9.1/gems/rhc-0.99.3/lib/rhc/wizard.rb:46:in `each'
	from /home/sunwei/.gem/ruby/1.9.1/gems/rhc-0.99.3/lib/rhc/wizard.rb:46:in `run'
	from /home/sunwei/.gem/ruby/1.9.1/gems/rhc-0.99.3/lib/rhc/commands/app.rb:285:in `check_sshkeys!'
	from /home/sunwei/.gem/ruby/1.9.1/gems/rhc-0.99.3/lib/rhc/commands/app.rb:291:in `run_git_clone'
	from /home/sunwei/.gem/ruby/1.9.1/gems/rhc-0.99.3/lib/rhc/commands/app.rb:83:in `create'
	from /home/sunwei/.gem/ruby/1.9.1/gems/rhc-0.99.3/lib/rhc/commands.rb:99:in `block (3 levels) in to_commander'
	from /usr/local/share/gems/gems/commander-4.1.2/lib/commander/command.rb:180:in `call'
	from /usr/local/share/gems/gems/commander-4.1.2/lib/commander/command.rb:180:in `call'
	from /usr/local/share/gems/gems/commander-4.1.2/lib/commander/command.rb:155:in `run'
	from /usr/local/share/gems/gems/commander-4.1.2/lib/commander/runner.rb:402:in `run_active_command'
	from /home/sunwei/.gem/ruby/1.9.1/gems/rhc-0.99.3/lib/rhc/command_runner.rb:29:in `run!'
	from /usr/local/share/gems/gems/commander-4.1.2/lib/commander/delegates.rb:11:in `run!'
	from /home/sunwei/.gem/ruby/1.9.1/gems/rhc-0.99.3/lib/rhc/cli.rb:40:in `start'
	from /home/sunwei/.gem/ruby/1.9.1/gems/rhc-0.99.3/bin/rhc:57:in `<top (required)>'
	from /home/sunwei/bin/rhc:23:in `load'
	from /home/sunwei/bin/rhc:23:in `<main>'
Comment 5 John (J5) Palmieri 2012-10-01 12:16:15 EDT
This was fixed in my command-merge-master branch.  Chris' branch has now been merged with mine.  Please grab from git@github.com:J5/rhc.git and checkout the commands-merge-master branch or wait for the next ami and use the rhc on that.
Comment 6 Chandrika Gole 2012-10-02 19:29:44 EDT
verified this on AMI: fork_ami_US2597_US2599_US2813_US2817_US2872_US2816_US2814_202 (ami-7b40fd12)

[root@ip-10-145-185-183 ~]# rhc app create php2 php-5.3
Password: 

Creating application 'php2'
===========================

  Scaling:   no
  Namespace: cgoleuio
  Cartridge: php-5.3
  Gear Size: default

Your application's domain name is being propagated worldwide (this might take a minute)...
Your public ssh key must be uploaded to the OpenShift server.  Would you like us to upload it for you? (yes/no) yes

You can enter a name for your key, or leave it blank to use the default name. Using the same name as an existing key will overwrite the old key.

Since you do not have any keys associated with your OpenShift account,
your new key will be uploaded as the 'default' key

type: ssh-rsa
content:
AAAAB3NzaC1yc2EAAAABIwAAAQEA6mTc9Oftu6XPNg78qoA745Zy46YkHj/erRTvHzlGVLqcehkuJHR6nQkJm6pCAADWHZ2IWc2Hxo3fQ6ms0HfwaVp5avm0Z/edUD+me3SvmLlr9cReFBmwaOLxQAKQVyKXBrKbvwJ1LTYqu9fVSthodU+rnXuT102u/fB1MaXgdnkdDloD+q3cTG4aXzuB6WyHzRVC
zHhas6B74F3VT7+ThcIyO/+27i9HfOPAT/khcEALjy1f5V5RphuxBYvC/cnxfeizbVRP6C9gFprMkcTuQssxzfNaisM1qOx0je/InY5YYuXrgBFr1N/ZX0VQ4uytObwkkjucOAdXI/1GXh+zFQ==
fingerprint: 6e:54:fd:e1:7d:56:79:98:52:75:2d:50:02:7a:02:cc
Uploading key 'default' from /root/.ssh/id_rsa.pub
The authenticity of host 'php2-cgoleuio.dev.rhcloud.com (10.145.185.183)' can't be established.
RSA key fingerprint is 4a:31:0a:9f:0e:55:d0:98:b0:b3:75:64:82:81:a1:62.
Are you sure you want to continue connecting (yes/no)? yes
Initialized empty Git repository in /root/php2/.git/
done

php2 @ http://php2-cgoleuio.dev.rhcloud.com/
============================================
Created: 7:28 PM
   UUID: 1dfd775b9d294bc4a52729bced03493b
Git URL: ssh://1dfd775b9d294bc4a52729bced03493b@php2-cgoleuio.dev.rhcloud.com/~/git/php2.git/
SSH URL: ssh://1dfd775b9d294bc4a52729bced03493b@php2-cgoleuio.dev.rhcloud.com

Cartridges:
  php-5.3
RESULT:
Application php2 was created.

[root@ip-10-145-185-183 ~]#

Note You need to log in before you can comment on or make changes to this bug.