Bug 860999 - [RHEVM]Unable to create VM from the RHEVM
[RHEVM]Unable to create VM from the RHEVM
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Pranith Kumar K
Rahul Hinduja
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 05:39 EDT by Rahul Hinduja
Modified: 2015-08-10 15:30 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.3.0rhsvirt1-7.el6rhs.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-10 03:45:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
brick logs (938.62 KB, text/x-log)
2012-09-27 05:39 EDT, Rahul Hinduja
no flags Details

  None (edit)
Description Rahul Hinduja 2012-09-27 05:39:36 EDT
Created attachment 617978 [details]
brick logs

Description of problem:
=======================

Unable to create VM from the RHEVM. Detailed steps mentioned below

Version-Release number of selected component (if applicable):
=============================================================

[root@rhs-client6 ~]# gluster --version
glusterfs 3.3.0rhsvirt1 built on Sep 25 2012 14:53:06

[root@rhs-client6 ~]# rpm -qa | grep gluster
glusterfs-3.3.0rhsvirt1-6.el6rhs.x86_64
glusterfs-rdma-3.3.0rhsvirt1-6.el6rhs.x86_64
vdsm-gluster-4.9.6-14.el6rhs.noarch
gluster-swift-plugin-1.0-5.noarch
gluster-swift-container-1.4.8-4.el6.noarch
org.apache.hadoop.fs.glusterfs-glusterfs-0.20.2_0.2-1.noarch
glusterfs-fuse-3.3.0rhsvirt1-6.el6rhs.x86_64
glusterfs-geo-replication-3.3.0rhsvirt1-6.el6rhs.x86_64
gluster-swift-proxy-1.4.8-4.el6.noarch
gluster-swift-account-1.4.8-4.el6.noarch
gluster-swift-doc-1.4.8-4.el6.noarch
glusterfs-server-3.3.0rhsvirt1-6.el6rhs.x86_64
gluster-swift-1.4.8-4.el6.noarch
gluster-swift-object-1.4.8-4.el6.noarch


Steps Carried:
==============

1. 2*2 distributed replicate volume formed from 4 servers, one brick from each server. Server and brick details:

> rhs-client6.lab.eng.blr.redhat.com:/disk1 (/dev/mapper/vg1-lvol0 mounted on /disk1)
> rhs-client7.lab.eng.blr.redhat.com:/disk1 (/dev/mapper/vg1-lvol0 mounted on /disk1)
> rhs-client8.lab.eng.blr.redhat.com:/disk1 (/dev/mapper/vg1-lvol0 mounted on /disk1)
> rhs-client9.lab.eng.blr.redhat.com:/disk1 (/dev/mapper/vg1-lvol0 mounted on /disk1)

Size of each /disk1 is 500 GB

Note: the /dev/mapper/vg1-lvol0 is mounted on /disk1 but there was no entry in /etc/fstab

2. Created 5 VM's from RHEVM.

3. Powered OFF client6 and client8.

4. Stoped and removed all the existing 5 VM's.

5. Powered ON client6 and client8.

6. Since the entry was not put in /etc/fstab. All the files on client6 and client8 got self-healed to /disk1 on the local drive (not /dev/mapper/vg1-lvol0)

7. Self-heal was successful.

8. Powered OFF client7 and client9.

10. Created new VM's from RHEVM.

11. Powered ON client7 and client9.

12. Since the entry was not put in /etc/fstab. All the files on client7 and client9 getting self-healed to /disk1 on the local drive (not /dev/mapper/vg1-lvol0)

13. Since /dev/mapper/vg1-lvol0 was not mounted because of no entry in fstab, we manually mounted and added the entry to /etc/fstab.

14. Try to create new VM's from RHEVM. Which is unable to create. The behaviour is as follows

> We are able to select template for the VM creation

> Clicked OK to proceed.

> It shows the VM entry with image-locked status.

> After 10-15 secs, the VM is no more listed in RHEVM tab.

Also, following are the error messages logged in brick logs:

[2012-09-27 05:59:52.415338] E [posix-aio.c:248osix_aio_writev_complete] 0-dist-rep-rhevh-posix: writev(async) failed fd=33,offset=0 (-22/Invalid argument)
[2012-09-27 05:59:52.415386] I [server3_1-fops.c:1414:server_writev_cbk] 0-dist-rep-rhevh-server: 52063: WRITEV 0 (5dd06050-9f23-47fd-9d4f-9776e89502de) ==> -1 (Invalid
argument)
[2012-09-27 05:59:52.425487] E [posix-aio.c:248osix_aio_writev_complete] 0-dist-rep-rhevh-posix: writev(async) failed fd=33,offset=0 (-22/Invalid argument)
[2012-09-27 05:59:52.425523] I [server3_1-fops.c:1414:server_writev_cbk] 0-dist-rep-rhevh-server: 52094: WRITEV 0 (5dd06050-9f23-47fd-9d4f-9776e89502de) ==> -1 (Invalid
argument)


From RHEVM alerts:

2012-Sep-27, 13:14:47Failed to create VM test_vm1 (User: admin@internal).


Actual results:
===============
Failed to create VM


Expected results:
=================

Creation of VM should be successful

Additional info:
================

brick log is attached
Comment 2 Amar Tumballi 2012-10-23 06:49:43 EDT
noticed this bug now as it was in Pranith's name. This issue is same as bug 859406 

patch submitted @ https://code.engineering.redhat.com/gerrit/#/c/61/ and fix included in glusterfs-3.3.0rhsvirt1-7.el6rhs.x86_64 release.
Comment 3 Rahul Hinduja 2012-12-04 03:52:05 EST
Verified as per the steps. VM creation is successful.

Verified with build: "Beta - RHS 2.0 with virt support" (glusterfs-3.3.0rhsvirt1-8.el6rhs.x86_64)

Note You need to log in before you can comment on or make changes to this bug.