Bug 861021 - [fork]Should show more detail about the app's status when using rhc app show --apache
[fork]Should show more detail about the app's status when using rhc app sho...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: John (J5) Palmieri
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 06:23 EDT by Wei Sun
Modified: 2015-05-14 22:05 EDT (History)
3 users (show)

See Also:
Fixed In Version: fork_ami_US2597_US2599_US2813_US2817_US2872_US2816_US2814_226
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:47:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wei Sun 2012-09-27 06:23:52 EDT
Description of problem:
Run "rhc app show --apache",will show app's status,but don't show gear information clearly.

Version-Release number of selected component (if applicable):
fork_ami_US2597_US2599_US2813_US2817_US2872_172

How reproducible:
always

Steps to Reproduce:
1.create app
2.rhc app show --apache $appname
3.
  
Actual results:
OpenShiftmatoMacBook-Pro:~ OpenShift$ rhc app show --apache phps
Password: ******
stopped
stopped

Expected results:
Should  show clear message,such as
Application '6212b993c0' is stopped
Application 'phps' is stopped

Additional info:
Comment 1 Clayton Coleman 2012-10-10 11:17:14 EDT
I don't think is intended.
Comment 2 John (J5) Palmieri 2012-10-10 16:41:28 EDT
Fixed this to show gear groups.

WARNING: After discussion I changed the --apache flag to --state as --apache does not describe what we are showing

New output:

$ rhc app show --state app2

RESULT:
Geargroup nodejs-0.6 is started
Geargroup mysql-5.1 is new
Geargroup nodejs-0.6+haproxy-1.4 is started
Comment 3 Wei Sun 2012-10-10 22:29:04 EDT
verified on devenv_2311
client build from fork_ami_US2597_US2599_US2813_US2817_US2872_US2816_US2814_226

Steps:
1. create an application
2.show application's status
rhc app show --state $appname

Result:
[sunwei@dhcp-8-229 dev]$ rhc app show --state nodejsscaletest
Password: ******


RESULT:
Geargroup nodejs-0.6 is started
Geargroup nodejs-0.6+haproxy-1.4 is started

Note You need to log in before you can comment on or make changes to this bug.