Bug 861025 - service rpcbind do not allow to specify command line options
service rpcbind do not allow to specify command line options
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpcbind (Show other bugs)
17
All All
unspecified Severity medium
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 06:36 EDT by Tigran Mkrtchyan
Modified: 2012-12-20 10:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:55:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a patch for /lib/systemd/system/rpcbind.service to fix the issue (325 bytes, patch)
2012-09-27 06:37 EDT, Tigran Mkrtchyan
no flags Details | Diff

  None (edit)
Description Tigran Mkrtchyan 2012-09-27 06:36:28 EDT
Description of problem:
The /usr/sbin/rpcbind accepts some command line options on startup, like -i, -l.
In pre-systemd times it was possible to specify such options in /etc/sysconfig/rpcbind file. With introduction of systemd the startup options are hard coded in /lib/systemd/system/rpcbind.service and there is no way to customize it.

Version-Release number of selected component (if applicable):
rpcbind-0.2.0-16.fc17


How reproducible:
always

Steps to Reproduce:
1. set an option in /etc/sysconfig/rpcbind
2. restart rpcbind service
3. check that new option is used
  
Actual results:
option is ignored

Expected results:
option is included

Additional info:

The attached file fixes this regression.

Tigran
Comment 1 Tigran Mkrtchyan 2012-09-27 06:37:41 EDT
Created attachment 617995 [details]
a patch for /lib/systemd/system/rpcbind.service to fix the issue
Comment 2 Tholme 2012-09-28 17:07:08 EDT
You should just create a override file in /etc/systemd/system/rpcbind.service, with for example the following text:

.include /lib/systemd/system/rpcbind.service
[Service]
ExecStart=/sbin/rpcbind -w

This allow you to override any of the options specified in rpcbind.service, not only add new options to the command line.
Comment 3 Tigran Mkrtchyan 2012-09-30 15:36:30 EDT
Most of other services do have a possibility to be configured by files in /etc/sysconfig. Why (a) rpcbind should be an exception and (b) switch to systemd do not supports old configuration files?
Comment 4 Fedora Update System 2012-10-14 22:39:08 EDT
rpcbind-0.2.0-18.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/rpcbind-0.2.0-18.fc18
Comment 5 Fedora Update System 2012-10-14 22:40:32 EDT
rpcbind-0.2.0-17.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/rpcbind-0.2.0-17.fc17
Comment 6 Fedora Update System 2012-10-15 13:39:35 EDT
Package rpcbind-0.2.0-18.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rpcbind-0.2.0-18.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16144/rpcbind-0.2.0-18.fc18
then log in and leave karma (feedback).
Comment 7 Tigran Mkrtchyan 2012-10-16 06:51:03 EDT
well, it works. But why you have changed the variable name? The old one was RPCBIND_ARGS while the new one is RPCBINDOPTS. existing files still ignored.
Comment 8 Steve Dickson 2012-10-16 08:14:35 EDT
(In reply to comment #7)
> well, it works. But why you have changed the variable name? The old one was
> RPCBIND_ARGS while the new one is RPCBINDOPTS. existing files still ignored.
I tried to stay with the same naming convention that is used in /etc/sysconfig/nfs.
Comment 9 Tigran Mkrtchyan 2012-10-16 10:25:07 EDT
But then it's (still) not backward compatible.
Comment 10 Fedora Update System 2012-10-23 13:34:41 EDT
rpcbind-0.2.0-20.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/rpcbind-0.2.0-20.fc18
Comment 11 Michal Schmidt 2012-10-24 09:08:45 EDT
(In reply to comment #3)
> Most of other services do have a possibility to be configured by files in
> /etc/sysconfig. Why (a) rpcbind should be an exception

Some service have that, but I'm not sure they're the majority.

> (b) switch to systemd do not supports old configuration files?

The main argument against /etc/sysconfig/* files says that they're specific to Fedora (+ its derivatives). In an ideal world every daemon would be fully configurable using a config file in /etc (or say, /etc/$DAEMON/*). There'd be no the need to change the command line. The config file name would be determined by upstream and so there would be unification across Linux distributions. Also, editing a real config file (with hopefully self-explanatory option names and with in-line comments) is nicer than having to type in cryptic command line options.

In the present real world there are however some daemons where editing the command line can be necessary. With SysV initscripts these were supported using /etc/sysconfig/* because there was no other way (the initscripts themselves were not %config files, so should not have been edited). With the transition to systemd there appeared a new way - there is the support for overriding the unit files (as in comment #2). That's why /etc/sysconfig/* files are not strictly needed anymore.

There is no consensus among Fedora developers on whether to keep using /etc/sysconfig/*. Steve as the package maintainer can decide as he likes.
Comment 12 Fedora Update System 2012-12-20 10:56:00 EST
rpcbind-0.2.0-20.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.