This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 861047 - [US2105][fork]Failed to restore apps using snapshot tarball
[US2105][fork]Failed to restore apps using snapshot tarball
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Mrunal Patel
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 07:48 EDT by jizhao
Modified: 2015-05-14 22:05 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:49:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jizhao 2012-09-27 07:48:44 EDT
Description of problem:
Always get "Archive at app3.tar.gz does not contain the target application: ./*/app3" while restoring apps. This may be caused by the directory structure changes.

Version-Release number of selected component (if applicable):
fork_ami_US2105_169
rhc-0.99.2

How reproducible:
Always

Steps to Reproduce:
1.Create an app
2.Save snapshot of it
$ rhc app snapshot save -a <appname> -d
3.Restore the app
$ rhc app snapshot restore -a <appname> -f app3.tar.gz -d
  
Actual results:
<----------------output---------------->
Archive at app3.tar.gz does not contain the target application: ./*/app3
If you created this archive rather than exported with rhc-snapshot, be sure
the directory structure inside the archive starts with ./<app_uuid>/
i.e.: tar -czvf <app_name>.tar.gz ./<app_uuid>/
<-------------------------------------->


Expected results:
The app should be restored successfully.

Additional info:
Comment 1 jizhao 2012-09-27 08:04:31 EDT
After embedding mysql-5.1 to the app, restore will succeed.
Comment 3 Jianwei Hou 2012-09-28 04:45:57 EDT
Tested on fork_ami_US2105_178
Seems the above fix has not come into latest ami, so leave this bug for next fork_ami
Comment 4 Jianwei Hou 2012-09-29 03:14:22 EDT
Tested on fork_ami_us2105_189, and still reproduced this problem.

The fixing code has not merged in, so I replaced current code with fix in comment 2 and it works for me.

Assign it back now since the fix has not came in for two ami builds.
Comment 5 Mrunal Patel 2012-10-01 10:52:54 EDT
Fix will be available in next AMI.
Comment 6 Chandrika Gole 2012-10-01 19:24:57 EDT
Test this on devenv2259 and it works
Comment 7 Chandrika Gole 2012-10-02 20:08:56 EDT
verified this on AMI: fork_ami_US2105_203 (ami-3943fe50)

Note You need to log in before you can comment on or make changes to this bug.