Bug 861095 - [hi_IN] duplicate words appear in two msgid translations
[hi_IN] duplicate words appear in two msgid translations
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Engineering Localization bugs mailing list
Entitlement Bugs
: Translation
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-09-27 09:49 EDT by John Sefler
Modified: 2013-01-07 23:03 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 23:03:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-09-27 09:49:50 EDT
Description of problem:

There are duplicate words in the following Hindi translations.  I also got confirmation from aalam@redhat.com that this is indeed a translation bug.

# The word 'नहीं' is repeated.
msgid "Server URL can not be None"
msgstr "सर्वर URL कोई नहीं नहीं हो सकता है"

# The word 'सदस्यता' is repeated.
msgid "This system does not match subscription limits."
msgstr "यह सदस्यता सदस्यता सीमा से मेल नहीं खाता है."


Version-Release number of selected component (if applicable):
[root@rhsm-accept-rhel5 rhsm]# rpm -q subscription-manager
subscription-manager-1.0.20-1.el5

How reproducible:


Steps to Reproduce:
[root@rhsm-accept-rhel5 rhsm]# msgunfmt --no-wrap /usr/share/locale/hi/LC_MESSAGES/rhsm.mo | grep "This system does not match" -A1
msgid "This system does not match subscription limits."
msgstr "यह सदस्यता सदस्यता सीमा से मेल नहीं खाता है."
           ^^^^^ ^^^^^
           DUPLICATE WORDS IN THE TRANSLATION

[root@rhsm-accept-rhel5 rhsm]# msgunfmt --no-wrap /usr/share/locale/hi/LC_MESSAGES/rhsm.mo | grep "Server URL can not be None" -A1msgid "Server URL can not be None"
msgstr "सर्वर URL कोई नहीं नहीं हो सकता है"
                   ^^^ ^^^
                   DUPLICATE WORDS IN THE TRANSLATION
Comment 1 RHEL Product and Program Management 2012-09-27 10:07:23 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Bryan Kearney 2012-09-27 10:11:02 EDT
aalam@redhat.com: Can you fix this in zanata and we will pull the strings again?
Comment 3 Ankit Patel 2012-09-27 10:29:59 EDT
Rajesh,

Can you please fix this in Zanata?

Thanks!
Ankit
Comment 4 John Sefler 2012-09-27 11:18:47 EDT
(In reply to comment #0)
> [root@rhsm-accept-rhel5 rhsm]# msgunfmt --no-wrap /usr/share/locale/hi/LC_MESSAGES/rhsm.mo | grep "Server URL can not be None" -A1
> msgid "Server URL can not be None"
> msgstr "सर्वर URL कोई नहीं नहीं हो सकता है"
>                    ^^^ ^^^
>                    DUPLICATE WORDS IN THE TRANSLATION

Upon further review, I found some test notes that indicate this occurance of a double word in the msgstr is correct for this translation.  Please re-confirm.  Thank you.
Comment 5 Rajesh Ranjan 2012-09-28 01:31:19 EDT
(In reply to comment #4)
> (In reply to comment #0)
> > [root@rhsm-accept-rhel5 rhsm]# msgunfmt --no-wrap /usr/share/locale/hi/LC_MESSAGES/rhsm.mo | grep "Server URL can not be None" -A1
> > msgid "Server URL can not be None"
> > msgstr "सर्वर URL कोई नहीं नहीं हो सकता है"
> >                    ^^^ ^^^
> >                    DUPLICATE WORDS IN THE TRANSLATION
> 
> Upon further review, I found some test notes that indicate this occurance of
> a double word in the msgstr is correct for this translation.  Please
> re-confirm.  Thank you.

The above ^^ is alright, as you have already noticed. But I made one change in the translation of the above. Thanks!
Comment 6 Alex Wood 2012-10-01 16:56:01 EDT
commit 1f50513f3394005c4e764f9ce650fd3a2f6c004d on axiom
Comment 8 John Sefler 2012-10-05 11:02:29 EDT
Verifying Version...
[root@jsefler-rhel59 ~]# rpm -q subscription-managersubscription-manager-1.0.21-1.el5


[root@jsefler-rhel59 ~]# msgunfmt --no-wrap /usr/share/locale/hi/LC_MESSAGES/rhsm.mo | grep "This system does not match" -A1
msgid "This system does not match subscription limits."
msgstr "यह तंत्र सदस्यता सीमा से मेल नहीं खाता है."

VERIFIED: The duplicate words in the msgstr have been removed


[root@jsefler-rhel59 ~]# msgunfmt --no-wrap /usr/share/locale/hi/LC_MESSAGES/rhsm.mo | grep "Server URL can not be None" -A1
msgid "Server URL can not be None"
msgstr "सर्वर URL कोई नहीं नहीं हो सकता है"

VERIFIED: The duplicate words in the msgstr for this msgid are acceptable - not a bug/typo.
Comment 10 errata-xmlrpc 2013-01-07 23:03:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.