Bug 861097 - Enabling and disabling performance translators repeatedly causes error
Enabling and disabling performance translators repeatedly causes error
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.0
x86_64 Linux
medium Severity medium
: ---
: RHGS 2.1.2
Assigned To: Raghavendra G
SATHEESARAN
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 09:54 EDT by SATHEESARAN
Modified: 2015-05-13 12:28 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0qa4-1
Doc Type: Bug Fix
Doc Text:
Previously on enabling or disabling a translator, a new graph was created and all the subsequent operations were displayed on the new graph. "Transport End point not connected" errors occurred if sufficient time was not available for the completion of all operations in progress. As a result a stale graph was displayed. With this update, these graphs work as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:22:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description SATHEESARAN 2012-09-27 09:54:17 EDT
Description of problem:
when enabling and disabling, performance translator( any of the following: md-cache/stat-prefetch, quick-read, io-cache, read-ahead, write-behind ) repeatedly for about an hour, causes error - "Transport endpoint is not connected"

Version-Release number of selected component (if applicable):
RHS 2.0.z

How reproducible:
consistently reproducible

Steps to Reproduce:
1. Disable performance translator ( any of the following: md-cache/stat-prefetch, quick-read, io-cache, read-ahead, write-behind )
2. After time interval of 5 seconds, again enable the same performance translator, disabled in step 1
3. Repeat the above procedure(step 1 and step 2), repeatedly for an hour
  
Actual results:
Getting error - "Transport endpoint not connected" after sometime

Expected results:
There should not be any error at the mount point - when performing any read/write operation

Additional info:
Above said error popped out after running the enable-disable cycle for over 21 minutes
Comment 2 Amar Tumballi 2012-10-21 22:43:49 EDT
after lock-migration, it should be seemless.
Comment 3 SATHEESARAN 2012-12-12 07:17:45 EST
Verified this bug on release glusterfs 3.4.0qa4.

Moving this bug to VERIFIED state
Comment 4 Scott Haines 2013-09-23 19:18:50 EDT
Retargeting for 2.1.z U2 (Corbett) release.
Comment 5 Pavithra 2014-01-15 04:29:51 EST
Du,

Can you please verify the edited doc text for technical accuracy?
Comment 7 errata-xmlrpc 2014-02-25 02:22:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.