Bug 861104 - rhel 6.4 qemu-img re-base performance (on local/nfs storage) worse than rhel5.9 when snapshot to a new disk
rhel 6.4 qemu-img re-base performance (on local/nfs storage) worse than rhel5...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.4
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Kevin Wolf
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 10:08 EDT by Xiaomei Gao
Modified: 2016-01-15 10:18 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-15 10:18:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Quan Wenli 2012-09-28 02:01:44 EDT
This is no regression in qcow2 rebase perfomrance compared with 6.3 release host, but significant degradation compared with rhel5.9 host.
Comment 3 Kevin Wolf 2012-09-28 07:25:17 EDT
> # time qemu-img rebase -f qcow2 -t none -b base_new.qcow2 -F qcow2 sn3.qcow2

What exactly are you comparing? RHEL 5 doesn't even know the -t option, it always uses the equivalent of -t writeback. For an apples-to-apples comparison you need to use the same option on RHEL 6.

Another thing to try is running a RHEL 5 qemu-img on a RHEL 6 machine or vice versa, in order to check if the difference is in qemu-img or possibly in the kernel or other components.
Comment 4 Xiaomei Gao 2012-09-28 21:32:02 EDT
(In reply to comment #3)
> > # time qemu-img rebase -f qcow2 -t none -b base_new.qcow2 -F qcow2 sn3.qcow2
> 
> What exactly are you comparing? RHEL 5 doesn't even know the -t option, it
> always uses the equivalent of -t writeback. For an apples-to-apples
> comparison you need to use the same option on RHEL 6.

Thanks for reminder. but -t writeback option on RHEL6 is also about 24 s.
 
> Another thing to try is running a RHEL 5 qemu-img on a RHEL 6 machine or
> vice versa, in order to check if the difference is in qemu-img or possibly
> in the kernel or other components.

Running a RHEL 5 qemu-img on a RHEL 6 machine and test result is 6.722 s, so the difference is in qemu-img.
Comment 5 Kevin Wolf 2012-10-12 10:50:33 EDT
Okay, first part of the explanation is this on RHEL 5:

Formatting 'base.qcow2', fmt=qcow2, size=8388608 kB
Formatting 'sn1.qcow2', fmt=qcow2, backing_file=base.qcow2, backing_fmt=qcow2, size=8388608 kB
Formatting 'sn2.qcow2', fmt=qcow2, backing_file=sn1.qcow2, backing_fmt=qcow2, size=8388608 kB
Formatting 'sn3.qcow2', fmt=qcow2, backing_file=sn2.qcow2, backing_fmt=qcow2, size=8388608 kB

It doesn't actually creaet 20G images there, but only 8G images, like base.qcow2. But even when I make it always 8G there's still some difference between RHEL 5 and upstream qemu (ever since rebase was introduced) that I need to figure out...
Comment 12 Steve Whitehouse 2015-12-11 08:34:29 EST
Is there an NFS component to this bug? I couldn't figure out whether there was or not from the above.
Comment 13 Chao Yang 2015-12-13 20:00:14 EST
Yanhui,

Could you please try to provide the info that Steve needs?
Comment 14 Yanhui Ma 2015-12-15 04:27:25 EST
(In reply to Steve Whitehouse from comment #12)
> Is there an NFS component to this bug? I couldn't figure out whether there
> was or not from the above.
Hi, steve
From description of problem in comment 0, this issue existed on both local storage and nfs storage.

Note You need to log in before you can comment on or make changes to this bug.