Bug 861116 - [RFE] end of upgrade script should prompt/mention start services
[RFE] end of upgrade script should prompt/mention start services
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configure (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity medium
: beta4
: ---
Assigned To: Steve Linabery
Giulio Fidente
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 10:41 EDT by Dave Johnson
Modified: 2012-12-04 10:22 EST (History)
4 users (show)

See Also:
Fixed In Version: aeolus-conductor-0.13.18-1.el6cf
Doc Type: Enhancement
Doc Text:
End up upgrade script prompts/mentions (re)start services that were stopped at the beginning of the upgrade process. This bug fix prompts the user to run 'aeolus-service-start'. This fis is implemented in case the user needs to undertake other actions prior to re-enabling CloudForms.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:22:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Johnson 2012-09-27 10:41:11 EDT
Description of problem:
=============================
It would be a better customer experience if our upgrade script prompted the user and asked if they wanted to (re)start the services that were stopped at the beginning of the upgrade process.

At the very least we should mention the user needs to run 'aeolus-service start'
Comment 2 Mike Orazi 2012-09-28 11:22:08 EDT
Per Mitch, the desire is to mention the user needs to restart (in case they have other actions they wish to take prior to re-enabling aeolus services).
Comment 3 Steve Linabery 2012-10-05 14:41:22 EDT
I wonder if it is worth mentioning in the output something about logging out of browser sessions pursuant to BZ860564
Comment 4 Steve Linabery 2012-10-05 14:53:44 EDT
(probably not in this command line tool)
Comment 5 Steve Linabery 2012-10-08 13:57:55 EDT
2bea002 on 1.1
d862691 on master
Comment 7 Giulio Fidente 2012-10-25 06:19:40 EDT
verified using aeolus-conductor-0.13.21-1.el6cf
Comment 8 Giulio Fidente 2012-10-25 06:20:34 EDT
pardon aeolus-configure-2.8.9-1.el6cf
Comment 10 errata-xmlrpc 2012-12-04 10:22:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.