Bug 861156 - libtranslit does not work with some m17n input methods like latn-post or latn-pre which are not specific to a single language
libtranslit does not work with some m17n input methods like latn-post or latn...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libtranslit (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daiki Ueno
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 12:20 EDT by Mike FABIAN
Modified: 2012-10-01 04:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-01 04:00:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
0001-Make-it-work-for-input-methods-like-latn-post-latn-p.patch (3.21 KB, patch)
2012-09-27 12:26 EDT, Mike FABIAN
no flags Details | Diff

  None (edit)
Description Mike FABIAN 2012-09-27 12:20:21 EDT
I found that problem when trying to add a de_DE.conf file to
ibus-typing-booster with these contents:

mfabian@ari:/usr/share/ibus-typing-booster/hunspell-tables
$ cat de_DE.conf 
license = GPL
serial_number = 2010922
icon = english.png
name = de_DE
description = This is a German typing booster engine table for De-De language
languages = de
author = Anish Patil <apatil@redhat.com> 
status_prompt = de
valid_input_chars = abcdefghijklmnopqrstuvwxyzäöüßABCDEFGHIJKLMNOPQRSTUVWXYZÄÖÜ
layout = us
auto_wildcard = TRUE
max_key_length = 50
auto_commit = FALSE
discard_invalid_key=FALSE
def_full_width_punct = TRUE
def_full_width_letter = TRUE
user_can_define_phrase = TRUE
pinyin_mode = FALSE
dynamic_adjust = TRUE 
hunspell_dict = de_DE.dic
ime_name = German - DE(Hunspell)
page_size = 6
symbol= De-DE(Hunspell)
lang_chars = esijanrtolcdugmphbyfvkwqxzäüößáéêàâñESIJANRTOLCDUGMPHBYFVKWQXZÄÜÖÉ-.
m17_mim_name = latn-post
encoding  = ISO8859-1
other_ime = True
setup = /usr/libexec/ibus-setup-typing-booster
tab_enable = Falsemfabian@ari:/usr/share/ibus-typing-booster/hunspell-tables
$ 

After doing that,

    /usr/libexec/ibus-engine-typing-booster --xml

segfaulted because it is using libtranslit to load the “latn-post” input
method which fails.
Comment 1 Mike FABIAN 2012-09-27 12:26:34 EDT
Created attachment 618201 [details]
0001-Make-it-work-for-input-methods-like-latn-post-latn-p.patch

Proposed patch to make it work. 

Also as a pull request here:

https://github.com/ueno/libtranslit/pull/1
Comment 2 Daiki Ueno 2012-10-01 04:00:56 EDT
You can use "t-latn-post" instead of "latn-post".

Note You need to log in before you can comment on or make changes to this bug.