Bug 861204 - yum.rpmtrans.RPMTransaction failed, aborting!
yum.rpmtrans.RPMTransaction failed, aborting!
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: packaging-team-maint
Karel Srot
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 15:46 EDT by gregrwm
Modified: 2014-10-14 00:36 EDT (History)
5 users (show)

See Also:
Fixed In Version: yum-3.2.29-59.el6
Doc Type: Bug Fix
Doc Text:
NO DOCS NEEDED
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 00:36:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace as requested (1.28 MB, text/plain)
2013-06-18 11:03 EDT, gregrwm
no flags Details

  None (edit)
Description gregrwm 2012-09-27 15:46:37 EDT
Description of problem:  yum fails to update or remove packages


Version-Release number of selected component (if applicable): yum 3.2.29 30.el6


Steps to Reproduce:
1.  make certain changes, eg to /etc/crontab or /var/log/mail/statistics
2.  try to remove the package (crontabs or sendmail)

  
Actual results:
  Erasing    : crontabs-1.10-33.el6.noarch
warning: /etc/crontab saved as /etc/crontab.rpmsave
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/yum/rpmtrans.py", line 407, in callback
  File "/usr/lib/python2.6/site-packages/yum/rpmtrans.py", line 511, in _unInstStop
  File "/usr/lib/python2.6/site-packages/yum/rpmtrans.py", line 258, in _scriptout
  File "/usr/lib/python2.6/site-packages/yum/history.py", line 972, in log_scriptlet_output
  File "/usr/lib/python2.6/site-packages/yum/sqlutils.py", line 168, in executeSQLQmark
sqlite3.OperationalError: unable to open database file
error: python callback <bound method RPMTransaction.callback of <yum.rpmtrans.RPMTransaction instance at 0x289f560>> failed, aborting!


Expected results:  remove the package


Additional info:  using --installroot=/foo
Comment 2 gregrwm 2012-09-27 21:28:25 EDT
when updating from
postgresql91         9.1.4   3PGDG.rhel6 to
postgresql91         9.1.5   1PGDG.rhel6:
...
  Cleanup    : postgresql91-test-9.1.4-3PGDG.rhel6.x86_64                                                                   21/31
  Cleanup    : postgresql91-server-9.1.4-3PGDG.rhel6.x86_64                                                                 22/31
Non-fatal POSTUN scriptlet failure in rpm package postgresql91-server
  Cleanup    : postgresql91.x86_64                                                                                          23/31
warning: %postun(postgresql91-server-9.1.4-3PGDG.rhel6.x86_64) scriptlet failed, exit status 1
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/yum/rpmtrans.py", line 407, in callback
  File "/usr/lib/python2.6/site-packages/yum/rpmtrans.py", line 511, in _unInstStop
  File "/usr/lib/python2.6/site-packages/yum/rpmtrans.py", line 258, in _scriptout
  File "/usr/lib/python2.6/site-packages/yum/history.py", line 972, in log_scriptlet_output
  File "/usr/lib/python2.6/site-packages/yum/sqlutils.py", line 168, in executeSQLQmark
sqlite3.OperationalError: unable to open database file
error: python callback <bound method RPMTransaction.callback of <yum.rpmtrans.RPMTransaction instance at 0x7f9d12894fc8>> failed, aborting!
Comment 3 gregrwm 2012-09-29 20:26:04 EDT
meanwhile, steps to workaround:

in order to remove crontabs, you have to put back the original /etc/crontabs.

in order to remove sendmail, you have to put back the original /var/log/mail/statistics

if you haven't seen reports of this until now, either nobody ever removes these packages, or, likely it's related to ==installroot.
Comment 4 gregrwm 2012-09-30 11:34:10 EDT
sorry, typo, you have to put back the original "/etc/crontab".
Comment 5 RHEL Product and Program Management 2012-12-14 03:12:46 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 James Antill 2013-04-15 16:46:45 EDT
> sqlite3.OperationalError: unable to open database file

 This means that yum can't open the history file, and that might have something to do with the installroot option. Can you check with the latest verison of yum, and if it's still a bug can you provide an strace?

 Worst case you can turn history recording off.
Comment 7 gregrwm 2013-06-18 11:03:41 EDT
Created attachment 762535 [details]
strace as requested

strace -o /tmp/stra yum --installroot=/vz/private/203 remove crontabs
...
Transaction Test Succeeded
Running Transaction
  Erasing    : cronie-anacron-1.4.4-7.el6.x86_64                                                                                                                     1/3 
could not open ts_done file: [Errno 2] No such file or directory: '/vz/private/203/var/lib/yum/transaction-done.2013-06-18.09:56.55'
  Erasing    : crontabs-1.10-33.el6.noarch                                                                                                                           2/3 
warning: /etc/crontab saved as /etc/crontab.rpmsave
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/yum/rpmtrans.py", line 407, in callback
  File "/usr/lib/python2.6/site-packages/yum/rpmtrans.py", line 511, in _unInstStop
  File "/usr/lib/python2.6/site-packages/yum/rpmtrans.py", line 258, in _scriptout
  File "/usr/lib/python2.6/site-packages/yum/history.py", line 972, in log_scriptlet_output
  File "/usr/lib/python2.6/site-packages/yum/sqlutils.py", line 168, in executeSQLQmark
sqlite3.OperationalError: unable to open database file
error: python callback <bound method RPMTransaction.callback of <yum.rpmtrans.RPMTransaction instance at 0x1646560>> failed, aborting!
/vz/private/203/var/lib/rpm: No such file or directory
Comment 8 RHEL Product and Program Management 2013-10-13 20:25:00 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 21 errata-xmlrpc 2014-10-14 00:36:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1410.html

Note You need to log in before you can comment on or make changes to this bug.