Bug 861226 - [abrt] calibre-0.8.63-1.fc17: UserDict.py:23:__getitem__:KeyError: 'COMP_LINE'
[abrt] calibre-0.8.63-1.fc17: UserDict.py:23:__getitem__:KeyError: 'COMP_LINE'
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: calibre (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
abrt_hash:7652c78fae4deefc24c2bdbf8ce...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 17:15 EDT by bug-zilla
Modified: 2012-11-04 12:34 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-04 12:34:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (274 bytes, text/plain)
2012-09-27 17:16 EDT, bug-zilla
no flags Details

  None (edit)
Description bug-zilla 2012-09-27 17:15:57 EDT
Version-Release number of selected component:
calibre-0.8.63-1.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
cmdline:        python2 /usr/bin/calibre-complete
kernel:         3.5.4-1.fc17.x86_64

backtrace:
:UserDict.py:23:__getitem__:KeyError: 'COMP_LINE'
:
:Traceback (most recent call last):
:  File "/usr/bin/calibre-complete", line 23, in <module>
:    sys.exit(complete.main())
:  File "/usr/lib64/calibre/calibre/utils/complete.py", line 159, in main
:    comp_line, pos = os.environ['COMP_LINE'], int(os.environ['COMP_POINT'])
:  File "/usr/lib64/python2.7/UserDict.py", line 23, in __getitem__
:    raise KeyError(key)
:KeyError: 'COMP_LINE'
:
:Local variables in innermost frame:
:self: {'SSH_ASKPASS': '/usr/libexec/openssh/gnome-ssh-askpass', 'GLADE_PIXMAP_PATH': ':', 'XDG_RUNTIME_DIR': '/run/user/waldek', 'LESSOPEN': '||/usr/bin/lesspipe.sh %s', 'QT_IM_MODULE': 'xim', 'LOGNAME': 'waldek', 'USER': 'waldek', 'PATH': '/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/waldek/.local/bin:/home/waldek/bin', 'XDG_VTNR': '2', 'GNOME_KEYRING_CONTROL': '/run/user/waldek/keyring-vc5nnn', 'WINDOWPATH': '2', 'SSH_AGENT_PID': '1278', 'LANG': 'pl_PL.UTF-8', 'TERM': 'xterm', 'SHELL': '/bin/bash', 'XAUTHORITY': '/var/run/gdm/auth-for-waldek-36B8C7/database', 'SESSION_MANAGER': 'local/unix:@/tmp/.ICE-unix/1300,unix/unix:/tmp/.ICE-unix/1300', 'SHLVL': '3', 'HISTSIZE': '1000', 'WINDOWID': '65011716', 'QT_PLUGIN_PATH': '/usr/lib64/kde4/plugins:/usr/lib/kde4/plugins', 'IMSETTINGS_INTEGRATE_DESKTOP': 'yes', 'GLADE_CATALOG_PATH': ':', 'GPG_AGENT_INFO': '/home/waldek/.gnupg/S.gpg-agent:1303:1', 'HOME': '/home/MyName', 'USERNAME': 'MyName', 'IMSETTINGS_MODULE': 'none', 'GLADE_MODULE_PATH': ':', 'KDE_IS_PRELINKED': '1', 'SSH_AUTH_SOCK': '/tmp/ssh-HFRUMMPn1113/agent.1113', 'GDMSESSION': 'xfce', 'XMODIFIERS': '@im=none', 'MAIL': '/var/spool/mail/waldek', 'QT_GRAPHICSSYSTEM_CHECKED': '1', 'XDG_SESSION_ID': '4', 'DBUS_SESSION_BUS_ADDRESS': 'unix:abstract=/tmp/dbus-X35lJ3lwUo,guid=3e695fbd99c0bb9bbb8096de00000067', '_': '/usr/bin/calibre-complete', 'KDEDIRS': '/usr', 'DESKTOP_SESSION': 'xfce', 'XDG_CONFIG_DIRS': '/etc/xdg', 'GNOME_KEYRING_PID': '1109', 'HOSTNAME': 'F17', 'HISTCONTROL': 'ignoredups', 'XDG_DATA_DIRS': '/usr/local/share:/usr/share', 'PWD': '/home/waldek', 'DESKTOP_STARTUP_ID': '', 'COLORTERM': 'Terminal', 'DISPLAY': ':1.0', 'XDG_MENU_PREFIX': 'xfce-', 'LS_COLORS': 'rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:*.pdf=00;33:*.ps=00;33:*.ps.gz=00;33:*.txt=00;33:*.patch=00;33:*.diff=00;33:*.log=00;33:*.tex=00;33:*.xls=00;33:*.xlsx=00;33:*.ppt=00;33:*.pptx=00;33:*.rtf=00;33:*.doc=00;33:*.docx=00;33:*.odt=00;33:*.ods=00;33:*.odp=00;33:*.xml=00;33:*.epub=00;33:*.abw=00;33:*.htm=00;33:*.html=00;33:*.shtml=00;33:*.wpd=00;33:', 'XDG_SEAT': 'seat0'}
:key: 'COMP_LINE'
Comment 1 bug-zilla 2012-09-27 17:16:01 EDT
Created attachment 618290 [details]
File: core_backtrace
Comment 2 Kevin Fenzi 2012-09-27 17:35:28 EDT
What were you doing when this happened? 

Can you duplicate it?
Comment 3 bug-zilla 2012-11-04 03:34:43 EST
Apologize for the lack of response for such a long time.
I don't remeber when it happened. Now with version 0.9.1 everything seems to be ok.
Comment 4 Kevin Fenzi 2012-11-04 12:34:59 EST
Great. No problem. :)

Note You need to log in before you can comment on or make changes to this bug.