Bug 861302 - python-pyramid needs python-paste-script >= 1.7.4
python-pyramid needs python-paste-script >= 1.7.4
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-paste-script (Show other bugs)
6.3
All Linux
unspecified Severity high
: rc
: ---
Assigned To: Python Maintainers
BaseOS QE - Apps
: Rebase
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 01:35 EDT by Tomas Dabašinskas
Modified: 2016-07-14 10:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-14 10:57:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Dabašinskas 2012-09-28 01:35:39 EDT
Hi,
I'm packaging python-pyramid for epel and I noticed that pyramid 1.2.7 needs python-paste-script >= 1.7.4, here's full list of packages that gets downloaded when running pip install pyramid == 1.2.7:

[tdabasin@iddqd env]$ grep ^Downloading log
Downloading/unpacking pyramid==1.2.7
Downloading/unpacking Chameleon>=1.2.3 (from pyramid==1.2.7)
Downloading/unpacking Mako>=0.3.6 (from pyramid==1.2.7)
Downloading/unpacking Paste>1.7 (from pyramid==1.2.7)
Downloading/unpacking PasteDeploy (from pyramid==1.2.7)
Downloading/unpacking PasteScript>=1.7.4 (from pyramid==1.2.7)
Downloading/unpacking WebOb>=1.0.2 (from pyramid==1.2.7)
Downloading/unpacking repoze.lru (from pyramid==1.2.7)
Downloading/unpacking zope.component>=3.6.0 (from pyramid==1.2.7)
Downloading/unpacking zope.interface>=3.5.1 (from pyramid==1.2.7)
Downloading/unpacking zope.deprecation (from pyramid==1.2.7)
Downloading/unpacking venusian>=1.0a1 (from pyramid==1.2.7)
Downloading/unpacking translationstring (from pyramid==1.2.7)
Downloading/unpacking ordereddict (from Chameleon>=1.2.3->pyramid==1.2.7)
Downloading/unpacking unittest2 (from Chameleon>=1.2.3->pyramid==1.2.7)
Downloading/unpacking MarkupSafe>=0.9.2 (from Mako>=0.3.6->pyramid==1.2.7)
Downloading/unpacking zope.event (from zope.component>=3.6.0->pyramid==1.2.7)

Any chance you could please bump python-paste-script to >= 1.7.4? 

I have tried building package in fedora against dist-6E-epel and it builds fine.
http://koji.fedoraproject.org/koji/taskinfo?taskID=4536245

I have noticed there's CVS patch in current python-paste-script pacakge in rhel-x86_64-workstation-6 I have not investigated if that patch has been applied by upstream in later versions.

If there's anything that you would like to to do (create new spec, test, etc.) please do not hesitate to ask.

Many thanks!
Comment 2 RHEL Product and Program Management 2013-10-13 20:24:53 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Petr Viktorin 2016-07-14 10:57:59 EDT
Red Hat Enterprise Linux version 6 is entering the Production 2 phase of its lifetime and this bug doesn't meet the criteria for it, i.e. only high severity issues will be fixed. Please see https://access.redhat.com/support/policy/updates/errata/ for further information.

Note You need to log in before you can comment on or make changes to this bug.