Bug 861311 - Interactive reinstall or upgrade rhev-h, at the page of configure password there is a truncated sentence on screen.
Interactive reinstall or upgrade rhev-h, at the page of configure password th...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 02:44 EDT by chencong
Modified: 2013-02-28 11:31 EST (History)
13 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-9.el6
Doc Type: Bug Fix
Doc Text:
Previously, when users reached the password page of Red Hat Enterprise Virtualization Hypervisor installation, an unnecessary message would appear underneath saying, 'do not contain dictionary words'. Now, no messages appear on the password page.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:31:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (1.23 MB, image/bmp)
2012-09-28 02:44 EDT, chencong
no flags Details
Screenshot for Correctpage (24.22 KB, image/jpeg)
2012-10-29 23:23 EDT, haiyang,dong
no flags Details
Screenshot for issue page (25.61 KB, image/jpeg)
2012-10-29 23:24 EDT, haiyang,dong
no flags Details

  None (edit)
Description chencong 2012-09-28 02:44:34 EDT
Created attachment 618427 [details]
screenshot

Description of problem:
Interactive reinstall or upgrade rhev-h, at the page of configure
password input correct current password and valid new password, move up
and down the arrow in current password field and new password field,
there will be appear a extra sentence on screen.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120926.0.el6_3

How reproducible:
Always

Steps to Reproduce:
1. Interactive reinstall rhev-hypervisor6-6.3-20120926.0.el6_3 or
upgrade rhev-hypervisor6-6.3-20120920.0.rhev31.el6_3 to
rhev-hypervisor6-6.3-20120926.0.el6_3.
2. Configure password and move up and down the arrow in current password
field and new password field, there will be appear a extra sentence.
3. Foucs on the screen.

Actual results:
There is a extra sentence on screen "do not contain dictionary words".

Expected results:
There shouldn't have any extra sentence on screen.

Additional info:

Thanks,
cochen
Comment 2 Lei Wang 2012-09-28 07:15:11 EDT
The full prompt sentence has been truncated, only one line left there.
Comment 4 Fabian Deutsch 2012-10-02 06:29:24 EDT
http://gerrit.ovirt.org/#/c/8292/

Tested as follows:
1. Install old rhevh
2. Boot with newer rhevh
3. Apply patch (drop to shell, apply patch, re-launch installer)
4. Enter current password
5. Enter new and simple password (123)
6. Confirm new password (123)
7. Warning about weak password is shown
8. Change new password (1234)
9. Warning about non-matching password and confirmation is shown and no additional line from the previous message is visible
Comment 6 haiyang,dong 2012-10-29 23:16:12 EDT
Test version:
rhev-hypervisor6-6.4-20121015.1.el6
ovirt-node-2.5.0-7.el6_4.noarch

Steps:
1. Install RHEVH
2. Boot again same RHEVH ISO
3. Select "Install or Upgrade" option
4. When  the installer comes up and offers to "Reinstall Hypervisor 6.4-20121015.1.el6" 
5. Enter configure admin password page
6. Enter "Current Password" and input correct admin password
7. Enter "Password" and input "123"
8. Enter "Confirm Password" and input "123"
9. Move the cursor at "Continue" button,it shown correct page(correctpage.png)
10.Then move the cursor in this order:
Continue->Back->Confirm Passwrod->Password->Current Password->Password
Then can seen the issue page(issuepage.png)


so this bug still exist, change the status into "ASSIGNED".
Comment 7 haiyang,dong 2012-10-29 23:23:27 EDT
Created attachment 635306 [details]
Screenshot for Correctpage
Comment 8 haiyang,dong 2012-10-29 23:24:10 EDT
Created attachment 635307 [details]
Screenshot for issue page
Comment 9 Fabian Deutsch 2012-11-13 08:39:39 EST
http://gerrit.ovirt.org/#/c/9215/

Steps:
1. Install RHEVH
2. Boot again same RHEVH ISO
3. Select "Install or Upgrade" option
4. When  the installer comes up and offers to "Reinstall Hypervisor 6.4-20121031.0.el6" 
5. Enter configure admin password page
6. Enter "Current Password" and input correct admin password
7. Enter "Password" and input "123"
8. Enter "Confirm Password" and input "123"
9. Press Caps Lock
10. Move the cursor at "Continue" button,it shown correct page
11.Then move the cursor in this order:
Continue->Back->Confirm Passwrod->Password->Current Password->Password

Now all words of the message are removed from the screen.
Comment 15 errata-xmlrpc 2013-02-28 11:31:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.