Bug 861343 - [US2105][fork] Can not successfully threaddump apps
[US2105][fork] Can not successfully threaddump apps
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Mrunal Patel
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 05:21 EDT by Jianwei Hou
Modified: 2015-05-14 22:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:50:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jianwei Hou 2012-09-28 05:21:24 EDT
Description of problem:
Can not threaddump jbossas/jbosseap app successfully on fork_ami_US2105_178
threaddump ruby-1.8/ruby-1.9 was successful, but return message should be modified since $OPENSHIFT_APP_NAME is removed.

Version-Release number of selected component (if applicable):
On fork_ami_US2105_178

How reproducible:
Always

Steps to Reproduce:
1. Create jbossas/jbosseap app and do threaddump for it
2. Create ruby-1.8/ruby-1.9 app and do threaddump for it

  
Actual results:
After step 1:
hjw@my apps$ rhc threaddump jbossas1
Password: ******

Node execution failure (invalid exit code from node).  If the problem persists please contact Red Hat support.
hjw@my apps$ rhc threaddump jbosseap1
Password: ***

Node execution failure (invalid exit code from node).  If the problem persists please contact Red Hat support.


After step 2:
hjw@my apps$ rhc threaddump ruby18
Password: ***


RESULT:
Success

The thread dump file will be available via: rhc app tail -a ruby18 -f ruby18/logs/error_log-20120928-000000-EST -o '-n 250'

hjw@my apps$ rhc app tail -a ruby18 -f ruby18/logs/error_log-20120928-000000-EST -o '-n 250'
Password: ***

Attempting to tail files: ruby18/logs/error_log-20120928-000000-EST
Use ctl + c to stop
Could not find any files matching glob


Expected results:
Should threaddump jbossas/jbosseap app successfully
For ruby apps, should return correct dump file path 

Additional info:
Comment 1 John Poelstra 2012-09-28 15:00:01 EDT
looking into today, might be related to sync to master
Comment 2 Mrunal Patel 2012-09-28 20:05:58 EDT
Fix will be available in next ami.
Comment 3 Jianwei Hou 2012-09-29 03:03:11 EDT
Verified on fork_ami_2105_189

Steps:
1. Create jbossas/jbosseap/ruby-1.8/ruby-1.9 apps
2. run 'rhc threddump' for created apps
3. tail files with rhc app tail


Result:
Threaddump and rhc app tail was successful.

Note You need to log in before you can comment on or make changes to this bug.