Bug 861360 - uploading failed with "chown_uploads" enabled
uploading failed with "chown_uploads" enabled
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: vsftpd (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiri Skala
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 06:45 EDT by xiali
Modified: 2014-11-09 17:35 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-19 04:37:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xiali 2012-09-28 06:45:52 EDT
Description of problem:

my config:
chown_uploads=YES
chown_username=adam
chown_upload_mode=0600

Version-Release number of selected component (if applicable):

vsftpd-3.0.0-2.fc17.x86_64

How reproducible:

100%

Steps to Reproduce:

lftp, uplpad anonymous
  
Actual results:

lftp: Delaying before reconnect

Expected results:

transferred

Additional info:
Comment 1 Evan McNabb 2012-11-04 22:57:15 EST
I'm hitting the exact same issue. Disabling these options in my existing configuration fixed the problem.
Comment 3 Jiri Skala 2013-02-05 08:05:47 EST
(In reply to comment #1)
> I'm hitting the exact same issue. Disabling these options in my existing
> configuration fixed the problem.

Hi,
do you have explicit setting of the option 'seccomp_sandbox'? Could you provide me vsftpd.conf?

My tests works fine when seccomp_sandbox=NO.

Thanks Jiri
Comment 4 Jiri Skala 2013-02-19 04:37:48 EST
This works for me with setting following option in vsftpd.conf:

seccomp_sandbox=NO

You have to set SELinux boolean:

# setsebool allow_ftpd_anon_write on

I'm going to close the bug with the status 'worksforme'. If the difficulties persist put here further information, mainly vsftpd.conf

Note You need to log in before you can comment on or make changes to this bug.