Bug 861368 - Debuginfo RPMs are not available ftp.redhat.com
Debuginfo RPMs are not available ftp.redhat.com
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-SystemTap_Beginners_Guide (Show other bugs)
6.5
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Jacquelynn East
ecs-bugs
: Documentation, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 07:32 EDT by Christos Triantafyllidis
Modified: 2015-07-26 18:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 23:08:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christos Triantafyllidis 2012-09-28 07:32:32 EDT
Description of problem:

In https://access.redhat.com/knowledge/docs/en-US/Red_Hat_Enterprise_Linux/6/html/SystemTap_Beginners_Guide/using-systemtap.html

the guide mentions configuring a new repository:

[rhel-debuginfo]
name=Red Hat Enterprise Linux $releasever - $basearch - Debug
baseurl=ftp://ftp.redhat.com/pub/redhat/linux/enterprise/$releasever/en/os/$basearch/Debuginfo/
enabled=1

This URL doesn't contain any debuginfo packages as:

"Things works a bit differently in RHEL6 with the RHN channels."

The procedure has changed and the systemtap upstream documentation has changed:
http://sources.redhat.com/git/gitweb.cgi?p=systemtap.git;a=commit;h=723d90dc57980faddeba50cd707ad9d9fdcf05f2

Could you please update the website documentation too?

Version-Release number of selected component (if applicable):
not applicable

How reproducible:
Every time

Steps to Reproduce:
1. Setup a repository as defined in the above documentation
2. Check the output of "yum repolist"
  
Actual results:
Not listing debug info packages

Expected results:
Listing debuginfo packages

Additional info:
Similar bugzilla was raised in past and closed when the systemtap package was updated.
Comment 1 Christos Triantafyllidis 2012-09-28 07:35:09 EDT
Forgot to add the other bugzilla link:
https://bugzilla.redhat.com/show_bug.cgi?id=683569

Cheers,
Christos
Comment 3 Jacquelynn East 2012-10-01 19:26:22 EDT

*** This bug has been marked as a duplicate of bug 810344 ***
Comment 4 François Cami 2012-10-04 07:13:00 EDT
This bug was created due to a support request I initiated because the SystemTap documentation on redhat.com is obsolete.
Please do not close and mark as duplicate of a bug I do not have access rights to.
Reopening.
Comment 5 Jacquelynn East 2012-10-21 20:48:48 EDT
The fix will be included in the upcoming release.

Note You need to log in before you can comment on or make changes to this bug.