Bug 861372 - Got Traceback while migration from rhn to rhsm.
Got Traceback while migration from rhn to rhsm.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-09-28 07:48 EDT by spandey
Modified: 2015-04-23 19:57 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-05 14:40:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description spandey 2012-09-28 07:48:55 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
1/1

Prerequisites:
Rhel5.9 with following subscription-manager rpm
subscription-manager-firstboot-1.0.20-1.el5
subscription-manager-1.0.20-1.el5
subscription-manager-migration-data-1.11.2.4-1.git.0.27879c1.el5
subscription-manager-gui-1.0.20-1.el5
subscription-manager-migration-1.0.20-1.el5
 

Steps to verify : 
Register client to rhn-classic and subscribe some additional subscription  .
migrate client from rhn to rhsm  using following command. 
“rhn-migrate-classic-to-rhsm --servicelevel PerMIUM -f”

Expected Result : 
Client should migrated from rhn-classic to rhsm , No error message should display on console.

Actual Result : 
 [root@dhcp193-98 ~]# rhn-migrate-classic-to-rhsm --servicelevel PerMIUM -f
Red Hat account: qa@redhat.com
Password: 

Retrieving existing RHN Classic subscription information ...
+----------------------------------+
System is currently subscribed to these RHN Classic Channels:
+----------------------------------+
rhel-x86_64-server-5
rhel-x86_64-server-5-beta
rhel-x86_64-server-5-beta-debuginfo
rhel-x86_64-rhev-agent-5-server-beta
rhel-x86_64-rhev-agent-5-server
rhel-x86_64-rhev-v2v-5-beta
rhel-x86_64-rhev-v2v-5
rhel-x86_64-rhev-mgmt-agent-5-beta
rhel-x86_64-rhev-mgmt-agent-5
rhel-x86_64-server-rhev-hdk-2-5
rhel-x86_64-server-rhev-hdk-2-5-beta
rhn-tools-rhel-x86_64-server-5
rhel-x86_64-server-vt-5
rhn-tools-rhel-x86_64-server-5-beta
rhel-x86_64-server-dts-5-beta-debuginfo
rhel-x86_64-server-vt-5-debuginfo

+-----------------------------------------------------+ 
No product certificates are mapped to these RHN Classic channels:
+-----------------------------------------------------+
rhel-x86_64-rhev-v2v-5-beta
rhel-x86_64-rhev-v2v-5
rhel-x86_64-rhev-mgmt-agent-5-beta
rhel-x86_64-rhev-mgmt-agent-5
rhel-x86_64-server-rhev-hdk-2-5
rhel-x86_64-server-rhev-hdk-2-5-beta
rhn-tools-rhel-x86_64-server-5
rhn-tools-rhel-x86_64-server-5-beta

+-----------------------------------------------------+ 
Installing product certificates for these RHN Classic channels:
+-----------------------------------------------------+
rhel-x86_64-server-5
rhel-x86_64-server-5-beta
rhel-x86_64-server-5-beta-debuginfo
rhel-x86_64-rhev-agent-5-server-beta
rhel-x86_64-rhev-agent-5-server
rhel-x86_64-server-vt-5
rhel-x86_64-server-dts-5-beta-debuginfo
rhel-x86_64-server-vt-5-debuginfo

Product certificates installed successfully to /etc/pki/product.

Preparing to unregister system from RHN Classic ...
Traceback (most recent call last):
  File "/usr/sbin/rhn-migrate-classic-to-rhsm", line 690, in ?
    main()
  File "/usr/sbin/rhn-migrate-classic-to-rhsm", line 675, in main
    unRegisterSystemFromRhnClassic(sc, sk)
  File "/usr/sbin/rhn-migrate-classic-to-rhsm", line 356, in unRegisterSystemFromRhnClassic
    result = sc.system.deleteSystems(sk, systemId)
  File "/usr/lib64/python2.4/xmlrpclib.py", line 1096, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib64/python2.4/xmlrpclib.py", line 1383, in __request
    verbose=self.__verbose
  File "/usr/lib64/python2.4/xmlrpclib.py", line 1131, in request
    errcode, errmsg, headers = h.getreply()
  File "/usr/lib64/python2.4/httplib.py", line 1143, in getreply
    response = self._conn.getresponse()
  File "/usr/lib64/python2.4/httplib.py", line 872, in getresponse
    response.begin()
  File "/usr/lib64/python2.4/httplib.py", line 336, in begin
    version, status, reason = self._read_status()
  File "/usr/lib64/python2.4/httplib.py", line 294, in _read_status
    line = self.fp.readline()
  File "/usr/lib64/python2.4/httplib.py", line 991, in readline
    s = self._read()
  File "/usr/lib64/python2.4/httplib.py", line 947, in _read
    buf = self._ssl.read(self._bufsize)
socket.sslerror: The read operation timed out
Comment 1 spandey 2012-09-28 07:51:45 EDT
rhsm.conf file output 

# Unified Entitlement Platform Configuration
[server]
# Server hostname:
hostname = subscription.rhn.redhat.com

# Server prefix:
prefix = /subscription

# Server port:
port = 443

# Set to 1 to disable certificate validation:
insecure = 0

# Set the depth of certs which should be checked
# when validating a certificate
ssl_verify_depth = 3

# Server CA certificate location:
ca_cert_dir = /etc/rhsm/ca/

# an http proxy server to use
proxy_hostname =

# port for http proxy server
proxy_port =

# user name for authenticating to an http proxy, if needed
proxy_user =

# password for basic http proxy auth, if needed
proxy_password =


rhsm.log output 


2012-09-28 15:45:43,128 [INFO]  @connection.py:490 - Using basic authentication as: qa@redhat.com
2012-09-28 15:45:43,128 [INFO]  @connection.py:511 - Connection Built: host: subscription.rhn.redhat.com, port: 443, handler: /subscription
2012-09-28 15:45:43,129 [DEBUG]  @connection.py:323 - Loading CA PEM certificates from: /etc/rhsm/ca/
2012-09-28 15:45:43,129 [DEBUG]  @connection.py:305 - Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem'
2012-09-28 15:45:43,130 [DEBUG]  @connection.py:305 - Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem'
2012-09-28 15:45:43,130 [DEBUG]  @connection.py:305 - Loading CA certificate: '/etc/rhsm/ca/candlepin-ca.pem'
2012-09-28 15:45:43,131 [DEBUG]  @connection.py:344 - Making request: GET /subscription/users/qa%40redhat.com/owners
2012-09-28 15:45:45,557 [DEBUG]  @connection.py:357 - Response status: 200
2012-09-28 15:45:45,559 [DEBUG]  @connection.py:323 - Loading CA PEM certificates from: /etc/rhsm/ca/
2012-09-28 15:45:45,560 [DEBUG]  @connection.py:305 - Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem'
2012-09-28 15:45:45,561 [DEBUG]  @connection.py:305 - Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem'
2012-09-28 15:45:45,562 [DEBUG]  @connection.py:305 - Loading CA certificate: '/etc/rhsm/ca/candlepin-ca.pem'
2012-09-28 15:45:45,562 [DEBUG]  @connection.py:344 - Making request: GET /subscription/users/qa%40redhat.com/owners
2012-09-28 15:45:47,932 [DEBUG]  @connection.py:357 - Response status: 200
2012-09-28 15:45:53,641 [INFO]  @rhn-migrate-classic-to-rhsm:482 - Using mapping file /usr/share/rhsm/product/RHEL-5/channel-cert-mapping.txt
2012-09-28 15:45:53,643 [INFO]  @rhn-migrate-classic-to-rhsm:499 - mapping found for : rhel-x86_64-server-5 = Server-Server-x86_64-dfb340743a6e-69.pem
2012-09-28 15:45:53,643 [INFO]  @rhn-migrate-classic-to-rhsm:499 - mapping found for : rhel-x86_64-server-5-beta = Server-Server-x86_64-dfb340743a6e-69.pem
2012-09-28 15:45:53,643 [INFO]  @rhn-migrate-classic-to-rhsm:499 - mapping found for : rhel-x86_64-server-5-beta-debuginfo = Server-Server-x86_64-dfb340743a6e-69.pem
2012-09-28 15:45:53,643 [INFO]  @rhn-migrate-classic-to-rhsm:499 - mapping found for : rhel-x86_64-rhev-agent-5-server-beta = Server-Server-x86_64-dfb340743a6e-69.pem
2012-09-28 15:45:53,643 [INFO]  @rhn-migrate-classic-to-rhsm:499 - mapping found for : rhel-x86_64-rhev-agent-5-server = Server-Server-x86_64-dfb340743a6e-69.pem
2012-09-28 15:45:53,644 [INFO]  @rhn-migrate-classic-to-rhsm:499 - mapping found for : rhel-x86_64-server-vt-5 = Server-Server-x86_64-dfb340743a6e-69.pem
2012-09-28 15:45:53,644 [INFO]  @rhn-migrate-classic-to-rhsm:499 - mapping found for : rhel-x86_64-server-dts-5-beta-debuginfo = RHB-x86_64-99c22e1e646f-180.pem
2012-09-28 15:45:53,644 [INFO]  @rhn-migrate-classic-to-rhsm:499 - mapping found for : rhel-x86_64-server-vt-5-debuginfo = Server-Server-x86_64-dfb340743a6e-69.pem
2012-09-28 15:45:53,644 [INFO]  @rhn-migrate-classic-to-rhsm:523 - certs to be installed: ['Server-Server-x86_64-dfb340743a6e-69.pem', 'RHB-x86_64-99c22e1e646f-180.pem']
2012-09-28 15:45:53,645 [INFO]  @rhn-migrate-classic-to-rhsm:537 - cp /usr/share/rhsm/product/RHEL-5/Server-Server-x86_64-dfb340743a6e-69.pem /etc/pki/product/69.pem
2012-09-28 15:45:53,645 [INFO]  @rhn-migrate-classic-to-rhsm:537 - cp /usr/share/rhsm/product/RHEL-5/RHB-x86_64-99c22e1e646f-180.pem /etc/pki/product/180.pem
2012-09-28 15:45:53,688 [INFO]  @rhn-migrate-classic-to-rhsm:355 - Deleting system 1023456909 from RHN Classic...
Comment 2 Alex Wood 2012-09-28 10:00:44 EDT
Are you able to reproduce this bug consistently?  This situation is strange because you are succeeding in your RHN connection to get the list of channels, but then failing to connect when it is time to unregister from RHN.  I don't actually know how to replicate this as it would require an intermittent connection to RHN.
Comment 3 spandey 2012-10-03 04:08:09 EDT
Yeah i am not able to repro this defect , above in this defect i got traceback which should not  happen ,so i raised this defect.
Comment 4 Alex Wood 2012-10-05 14:40:37 EDT
Since this bug can't really be reproduced and would occur only under very rare circumstances, I'm closing this as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.