Bug 861373 - contacts is superseded by gnome-contacts, but still blocks f17->f18 upgrades
contacts is superseded by gnome-contacts, but still blocks f17->f18 upgrades
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: contacts (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 07:49 EDT by Christophe Fergeau
Modified: 2012-10-09 10:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-09 10:39:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christophe Fergeau 2012-09-28 07:49:40 EDT
- Install contacts on f17
- Start a yum --releasever=18 distro-sync
-> there are dependency issues because contacts hasn't been rebuilt against the newer evolution-data-server

contacts has http://pkgs.fedoraproject.org/cgit/contacts.git/tree/dead.package
"Package is dead. The functionality has been replaced by gnome-contacts"

It seems to me that gnome-contacts should have an "Obsoletes: contacts" to help with upgrades.
Comment 1 Christophe Fergeau 2012-09-28 07:52:17 EDT
Error message on upgrade is 

Error: Package: contacts-0.12-15.fc17.x86_64 (@fedora/17)
           Requires: libedataserver-1.2.so.16()(64bit)
           Removing: evolution-data-server-3.4.4-3.fc17.x86_64 (@updates/17)
               libedataserver-1.2.so.16()(64bit)
           Updated By: evolution-data-server-3.5.92-1.fc18.x86_64 (fedora)
               Not found
Error: Package: contacts-0.12-15.fc17.x86_64 (@fedora/17)
           Requires: libebook-1.2.so.13()(64bit)
           Removing: evolution-data-server-3.4.4-3.fc17.x86_64 (@updates/17)
               libebook-1.2.so.13()(64bit)
           Updated By: evolution-data-server-3.5.92-1.fc18.x86_64 (fedora)
               Not found
Comment 2 Peter Robinson 2012-10-02 05:45:00 EDT
Oops, missed updating that. Thought I had done so. Adding obsoletes now.
Comment 3 Fedora Update System 2012-10-02 06:07:55 EDT
gnome-contacts-3.6.0-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gnome-contacts-3.6.0-2.fc18
Comment 4 Fedora Update System 2012-10-02 15:49:19 EDT
Package gnome-contacts-3.6.0-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-contacts-3.6.0-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15228/gnome-contacts-3.6.0-2.fc18
then log in and leave karma (feedback).
Comment 5 Peter Robinson 2012-10-09 10:39:14 EDT
This has been pushed to stable

Note You need to log in before you can comment on or make changes to this bug.