Bug 861374 - [Drupal]When update the drupal book, the index displays twice
[Drupal]When update the drupal book, the index displays twice
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
3.0
x86_64 Linux
high Severity medium
: 3.0
: ---
Assigned To: Hao Chang Yu
Ruediger Landmann
:
Depends On: 863927
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 07:57 EDT by zhaiyu
Modified: 2013-01-09 05:32 EST (History)
6 users (show)

See Also:
Fixed In Version: 3.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 23:11:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
index twice (81.28 KB, image/png)
2012-09-28 23:57 EDT, zhaiyu
no flags Details
first import (7.38 MB, application/x-gzip)
2012-10-07 22:25 EDT, zhaiyu
no flags Details
second import (7.39 MB, application/x-gzip)
2012-10-07 22:26 EDT, zhaiyu
no flags Details

  None (edit)
Description zhaiyu 2012-09-28 07:57:37 EDT
Description of problem:
As summary, update the drupal book by import twice, the index part in drupal book displays twice.

Like:
Preface
Preface
Chapter 1
Chapter 1
......

Version-Release number of selected component (if applicable):
3.1-0

How reproducible:
sometimes

Steps to Reproduce:
1.Run the command to generate drupal book
2.Import the drupal book 
3.Repeat step 1,2 again
  
Actual results:
As Description

Expected results:
Index displays normally.

Additional info:
Comment 1 zhaiyu 2012-09-28 23:56:23 EDT
As Bug 862907 #comment, the issue occurs in specific conditon.

1. Build the drupal at first time and import the drupal book
   $publican build --langs en-US --formats=drupal-book
   $cp ****.cvs /opt/***/drupal-6/sites/default/files/imports/
   $cp -a en-US/ /opt/***/drupal-6/sites/default/files/
2. Clean the drupal-book and rebuild the drupal book as Step 1
3. Check the result
Comment 2 zhaiyu 2012-09-28 23:57:24 EDT
Created attachment 618832 [details]
index twice
Comment 3 Hao Chang Yu 2012-10-01 21:37:42 EDT
I tried to import and update a few books several times but still couldn't reproduce the issue. Can you give me more information? That will be great if you can provide me the csv files of the 2 import.
Comment 4 matt jia 2012-10-02 00:20:12 EDT
> As Bug 862907 #comment, the issue occurs in specific conditon.
> 
> 1. Build the drupal at first time and import the drupal book
>    $publican build --langs en-US --formats=drupal-book
>    $cp ****.cvs /opt/***/drupal-6/sites/default/files/imports/
>    $cp -a en-US/ /opt/***/drupal-6/sites/default/files/
> 2. Clean the drupal-book and rebuild the drupal book as Step 1
> 3. Check the result

Hi Zhaiyu,

Follow the above steps to replicate the bug and failed .

Would you please send us the book you imported ?

Cheers, Matt Jia
Comment 6 zhaiyu 2012-10-07 22:25:19 EDT
Created attachment 623221 [details]
first import
Comment 7 zhaiyu 2012-10-07 22:26:32 EDT
Created attachment 623222 [details]
second import
Comment 8 zhaiyu 2012-10-07 22:29:15 EDT
(In reply to comment #4)
> > As Bug 862907 #comment, the issue occurs in specific conditon.
> > 
> > 1. Build the drupal at first time and import the drupal book
> >    $publican build --langs en-US --formats=drupal-book
> >    $cp ****.cvs /opt/***/drupal-6/sites/default/files/imports/
> >    $cp -a en-US/ /opt/***/drupal-6/sites/default/files/
> > 2. Clean the drupal-book and rebuild the drupal book as Step 1
> > 3. Check the result
> 
> Hi Zhaiyu,
> 
> Follow the above steps to replicate the bug and failed .
> 
> Would you please send us the book you imported ?
> 
> Cheers, Matt Jia

Hi Matt Jia

I have uploaded the import files in attachments, you can verify the bug in your local. If have problems, feel free to contact me.

Zhai Yu
Comment 9 zhaiyu 2012-10-07 22:31:02 EDT
(In reply to comment #3)
> I tried to import and update a few books several times but still couldn't
> reproduce the issue. Can you give me more information? That will be great if
> you can provide me the csv files of the 2 import.


Hi Hao

I have uploaded the import files in attachments, you can verify the bug in your local. If have problems, feel free to contact me.

Zhai Yu
Comment 10 zhaiyu 2012-10-08 01:20:21 EDT
Because the publican-doc-3.1-0.el6eng.t7 rpm is broken, the drupal book cannot be produced in build command. The block bug is 863927 for publican-doc-3.1-0.el6eng.t7.
Comment 11 zhaiyu 2012-10-08 04:34:32 EDT
Verified on publican-doc-3.1-0.el6eng.t8, the index issue has been fixed.

Note You need to log in before you can comment on or make changes to this bug.