Bug 861376 - IndexError: tuple index out of range
IndexError: tuple index out of range
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
ppc64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
abrt_hash:4cff82fa4687bff41bda863c8b7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 08:16 EDT by Mark Hamzy
Modified: 2012-11-22 21:41 EST (History)
4 users (show)

See Also:
Fixed In Version: anaconda-18.11-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 21:41:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (218.23 KB, text/plain)
2012-09-28 08:16 EDT, Mark Hamzy
no flags Details
File: product (6 bytes, text/plain)
2012-09-28 08:16 EDT, Mark Hamzy
no flags Details
File: type (9 bytes, text/plain)
2012-09-28 08:16 EDT, Mark Hamzy
no flags Details
File: environ (824 bytes, text/plain)
2012-09-28 08:16 EDT, Mark Hamzy
no flags Details

  None (edit)
Description Mark Hamzy 2012-09-28 08:16:00 EDT
Version-Release number of selected component:
anaconda-18.10

Additional info:
libreport version: 2.0.12
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.0-0.rc6.git0.2.fc18.ppc64
Comment 1 Mark Hamzy 2012-09-28 08:16:13 EDT
Created attachment 618537 [details]
File: anaconda-tb
Comment 2 Mark Hamzy 2012-09-28 08:16:20 EDT
Created attachment 618538 [details]
File: product
Comment 3 Mark Hamzy 2012-09-28 08:16:23 EDT
Created attachment 618539 [details]
File: type
Comment 4 Mark Hamzy 2012-09-28 08:16:25 EDT
Created attachment 618540 [details]
File: environ
Comment 5 Mark Hamzy 2012-09-28 20:09:07 EDT
With https://lists.fedorahosted.org/pipermail/anaconda-patches/2012-September/001338.html now gives:

Traceback (most recent call first):
  File "/tmp/updates/pyanaconda/errors.py", line 96, in _partitionErrorHandler
"])}"The installation will now terminate.") % {"errortxt": str(kwargs["exceptionn
  File "/tmp/updates/pyanaconda/errors.py", line 251, in cb
    rc = _map[exn.__class__.__name__](*args, **kwargs)
tition "/tmp/updates/pyanaconda/storage/partitioning.py", line 324, in doAutoParr
    if errorHandler.cb(exn) == ERROR_RAISE:
  File "/tmp/updates/pyanaconda/kickstart.py", line 266, in execute
    doAutoPartition(storage, ksdata)
  File "/tmp/updates/pyanaconda/kickstart.py", line 1558, in doKickstartStorage
    ksdata.autopart.execute(storage, ksdata, instClass)
teFile "/tmp/updates/pyanaconda/ui/gui/spokes/storage.py", line 333, in _doExecuu
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/tmp/updates/pyanaconda/threads.py", line 87, in run
    threading.Thread.run(self, *args, **kwargs)
ValueError: unsupported format character '


' (0xa) at index 66
Comment 6 Mark Hamzy 2012-09-28 20:35:19 EDT
You are missing the % format character.

diff --git a/pyanaconda/errors.py b/pyanaconda/errors.py
index 8917184..3b8de04 100644
--- a/pyanaconda/errors.py
+++ b/pyanaconda/errors.py
@@ -92,8 +92,8 @@ class ErrorHandler(object):
         return ERROR_RAISE
 
     def _partitionErrorHandler(self, *args, **kwargs):
-        message = _("The following errors occurred with your partitioning:\n\n%(errortxt)\n\n"
-                    "The installation will now terminate.") % {"errortxt": args[0]}
+        message = _("The following errors occurred with your partitioning:\n\n%(errortxt)s\n\n"
+                    "The installation will now terminate.") % {"errortxt": str(kwargs["exception"])}
         self.ui.showError(message)
         return ERROR_RAISE
Comment 7 Mark Hamzy 2012-09-28 20:37:05 EDT
By the way, do we really want to exit the installer because the automatic partitioning came up with a problem?
Comment 8 Chris Lumens 2012-10-01 10:14:13 EDT
PartitioningError is raised for real problems that occur during partition execution, where the user can't really do anything about it, so yeah it makes sense to exit here.
Comment 9 Fedora Update System 2012-10-02 10:12:41 EDT
anaconda-18.11-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.11-1.fc18
Comment 10 Fedora Update System 2012-10-02 15:47:03 EDT
Package anaconda-18.11-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.11-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15207/anaconda-18.11-1.fc18
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2012-10-03 20:57:28 EDT
anaconda-18.12-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.12-1.fc18
Comment 12 Adam Williamson 2012-11-22 21:41:46 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

Note You need to log in before you can comment on or make changes to this bug.