Bug 861382 - Crashes on start
Crashes on start
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 08:47 EDT by Tim Waugh
Modified: 2012-10-04 23:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-04 23:01:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2012-09-28 08:47:00 EDT
Description of problem:
Crashes immediately.

Version-Release number of selected component (if applicable):
gnome-disk-utility-3.6.0-1.fc18.x86_64

How reproducible:
100%

Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/gnome-disks...Reading symbols from /usr/lib/debug/usr/bin/gnome-disks.debug...done.
done.
(gdb) r
Starting program: /usr/bin/gnome-disks 
warning: "/usr/lib/debug/usr/lib64/libcairo-gobject.so.2.11200.2.debug": separate debug info file has no debug info
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
[New Thread 0x7fffed5ed700 (LWP 2631)]

(gnome-disks:2608): Pango-CRITICAL **: pango_glyph_item_split: assertion `split_index < orig->item->length' failed

Program received signal SIGSEGV, Segmentation fault.
get_run_list (state=0x7fffffffd820) at ellipsize.c:680
680							  run_iter->start_index - run_info->run->item->offset);
Missing separate debuginfos, use: debuginfo-install PackageKit-gtk3-module-0.8.3-3.fc18.x86_64 adwaita-gtk3-theme-3.6.0.2-1.fc18.x86_64 at-spi2-atk-2.6.0-1.fc18.x86_64 at-spi2-core-2.6.0-1.fc18.x86_64 cracklib-2.8.19-2.fc18.x86_64 dbus-libs-1.6.0-2.fc18.x86_64 expat-2.1.0-4.fc18.x86_64 fontconfig-2.10.1-1.fc18.x86_64 freetype-2.4.10-2.fc18.x86_64 gvfs-1.14.0-1.fc18.x86_64 harfbuzz-0.9.4-1.fc18.x86_64 libX11-1.5.0-3.fc18.x86_64 libXau-1.0.6-4.fc18.x86_64 libXcomposite-0.4.3-4.fc18.x86_64 libXcursor-1.1.13-2.fc18.x86_64 libXdamage-1.1.3-4.fc18.x86_64 libXext-1.3.1-2.fc18.x86_64 libXfixes-5.0-3.fc18.x86_64 libXi-1.6.1-2.fc18.x86_64 libXinerama-1.1.2-2.fc18.x86_64 libXrandr-1.4.0-1.fc18.x86_64 libXrender-0.9.7-2.fc18.x86_64 libXxf86vm-1.1.2-2.fc18.x86_64 libbluray-0.2.3-1.fc18.x86_64 libcanberra-0.29-4.fc18.x86_64 libcanberra-gtk3-0.29-4.fc18.x86_64 libcroco-0.6.6-1.fc18.x86_64 libdrm-2.4.39-1.fc18.x86_64 libffi-3.0.10-3.fc18.x86_64 libgcc-4.7.2-2.fc18.x86_64 libgcrypt-1.5.0-6.fc18.x86_64 libgpg-error-1.10-3.fc18.x86_64 libicu-49.1.1-5.fc18.x86_64 libogg-1.3.0-2.fc18.x86_64 libpng-1.5.12-1.fc18.x86_64 librsvg2-2.36.3-1.fc18.x86_64 libselinux-2.1.12-1.fc18.x86_64 libstdc++-4.7.2-2.fc18.x86_64 libtdb-1.2.10-16.fc18.x86_64 libtool-ltdl-2.4.2-7.fc18.x86_64 libvorbis-1.3.3-3.fc18.x86_64 libwayland-client-0.95.0-1.fc18.x86_64 libwayland-server-0.95.0-1.fc18.x86_64 libxcb-1.8.1-2.fc18.x86_64 libxml2-2.9.0-0rc1.fc18.x86_64 mesa-libEGL-9.0-0.2.fc18.x86_64 mesa-libGL-9.0-0.2.fc18.x86_64 mesa-libgbm-9.0-0.2.fc18.x86_64 mesa-libglapi-9.0-0.2.fc18.x86_64 nss-softokn-freebl-3.13.5-3.fc18.x86_64 pcre-8.31-2.fc18.x86_64 pixman-0.26.2-5.fc18.x86_64 xz-libs-5.1.2-2alpha.fc18.x86_64 zlib-1.2.7-8.fc18.x86_64
(gdb) bt
#0  get_run_list (state=0x7fffffffd820) at ellipsize.c:680
#1  _pango_layout_line_ellipsize (line=line@entry=0x942850, 
    attrs=<optimized out>, goal_width=goal_width@entry=39936)
    at ellipsize.c:751
#2  0x00007ffff6744965 in pango_layout_line_postprocess (
    wrapped=<optimized out>, state=<optimized out>, line=<optimized out>)
    at pango-layout.c:5220
Python Exception <type 'exceptions.ValueError'> Variable 'g_quarks' not found.: 
#3  process_line (state=0x7fffffffda90, layout=) at pango-layout.c:3653
Python Exception <type 'exceptions.ValueError'> Variable 'g_quarks' not found.: 
#4  pango_layout_check_lines (layout=) at pango-layout.c:3916
Python Exception <type 'exceptions.ValueError'> Variable 'g_quarks' not found.: 
#5  pango_layout_check_lines (layout=) at pango-layout.c:3791
Python Exception <type 'exceptions.ValueError'> Variable 'g_quarks' not found.: 
#6  0x00007ffff6745577 in pango_layout_get_extents_internal (layout=, ink_rect=
    0x0, logical_rect=<optimized out>, line_extents=0x0) at pango-layout.c:2491
Python Exception <type 'exceptions.ValueError'> Variable 'g_quarks' not found.: 
#7  0x00007ffff67459ce in pango_layout_get_pixel_extents (layout=layout@entry=
    , ink_rect=ink_rect@entry=0x0, logical_rect=logical_rect@entry=
    0x7fffffffdc10) at pango-layout.c:2699
Python Exception <type 'exceptions.ValueError'> Variable 'g_quarks' not found.: 
#8  0x00007ffff6745a1e in pango_layout_get_pixel_size (layout=layout@entry=, 
    width=width@entry=0x0, height=height@entry=0x7fffffffdc44)
    at pango-layout.c:2748
#9  0x00007ffff70fea21 in gtk_cell_renderer_text_get_preferred_height_for_width
Python Exception <type 'exceptions.ValueError'> Variable 'g_quarks' not found.: 
    (cell=<optimized out>, widget=, width=43, minimum_height=0x7fffffffddc8, 
    natural_height=0x7fffffffddcc) at gtkcellrenderertext.c:2232
#10 0x00007ffff70f5948 in gtk_cell_renderer_get_preferred_height_for_width (
Python Exception <type 'exceptions.ValueError'> Variable 'g_quarks' not found.: 
Python Exception <type 'exceptions.ValueError'> Variable 'g_quarks' not found.: 
    cell=cell@entry=, widget=widget@entry=, width=43, 
---Type <return> to continue, or q <return> to quit---
    minimum_height=minimum_height@entry=0x7fffffffddc8, 
    natural_height=natural_height@entry=0x7fffffffddcc)
    at gtkcellrenderer.c:1617
Python Exception <type 'exceptions.ValueError'> Variable 'g_quarks' not found.: 
#11 0x00007ffff70ece4f in gtk_cell_area_request_renderer (area=area@entry=, 
Python Exception <type 'exceptions.ValueError'> Variable 'g_quarks' not found.: 
Python Exception <type 'exceptions.ValueError'> Variable 'g_quarks' not found.: 
    renderer=, orientation=GTK_ORIENTATION_VERTICAL, widget=widget@entry=, 
    for_size=<optimized out>, for_size@entry=45, 
    minimum_size=minimum_size@entry=0x7fffffffddc8, 
    natural_size=natural_size@entry=0x7fffffffddcc) at gtkcellarea.c:3617
#12 0x00007ffff70ee7b0 in compute_group_size_for_opposing_orientation (
    natural_size=0x7fffffffddcc, minimum_size=0x7fffffffddc8, for_size=45, 
Python Exception <type 'exceptions.ValueError'> Variable 'g_quarks' not found.: 
Python Exception <type 'exceptions.ValueError'> Variable 'g_quarks' not found.: 
    widget=, group=0x8044d0, box=) at gtkcellareabox.c:1638
Python Exception <type 'exceptions.ValueError'> Variable 'g_quarks' not found.: 
#13 compute_size_for_opposing_orientation (box=box@entry=, 
Python Exception <type 'exceptions.ValueError'> Variable 'g_quarks' not found.: 
Python Exception <type 'exceptions.ValueError'> Variable 'g_quarks' not found.: 
    context=context@entry=, widget=widget@entry=, for_size=for_size@entry=145, 
    minimum_size=minimum_size@entry=0x7fffffffde28, 
    natural_size=natural_size@entry=0x7fffffffde2c) at gtkcellareabox.c:1771
#14 0x00007ffff70ee9f5 in gtk_cell_area_box_get_preferred_height_for_width (
Python Exception <type 'exceptions.ValueError'> Variable 'g_quarks' not found.: 
Python Exception <type 'exceptions.ValueError'> Variable 'g_quarks' not found.: 
Python Exception <type 'exceptions.ValueError'> Variable 'g_quarks' not found.: 
    area=, context=, widget=, width=145, minimum_height=0x7fffffffde7c, 
    natural_height=0x0) at gtkcellareabox.c:1889
#15 0x00007ffff72cd117 in gtk_tree_view_column_cell_get_size (
Python Exception <type 'exceptions.ValueError'> Variable 'g_quarks' not found.: 
    tree_column=tree_column@entry=, cell_area=cell_area@entry=0x0, 
    x_offset=x_offset@entry=0x0, y_offset=y_offset@entry=0x0, 
    width=width@entry=0x0, height=height@entry=0x7fffffffdf4c)
    at gtktreeviewcolumn.c:2913
---Type <return> to continue, or q <return> to quit---
Python Exception <type 'exceptions.ValueError'> Variable 'g_quarks' not found.: 
#16 0x00007ffff72b4648 in validate_row (tree_view=tree_view@entry=, tree=
    0x804400, node=0x7fffe8006f00, iter=iter@entry=0x7fffffffe030, 
    path=path@entry=0x879710) at gtktreeview.c:6106
Python Exception <type 'exceptions.ValueError'> Variable 'g_quarks' not found.: 
#17 0x00007ffff72b94a7 in validate_visible_area (tree_view=)
    at gtktreeview.c:6426
Python Exception <type 'exceptions.ValueError'> Variable 'g_quarks' not found.: 
#18 do_presize_handler (tree_view=) at gtktreeview.c:6782
#19 0x00007ffff72b9ac9 in presize_handler_callback (data=<optimized out>)
    at gtktreeview.c:6805
#20 0x00007ffff6db9df0 in gdk_threads_dispatch (data=0x8c73a0) at gdk.c:788
#21 0x00007ffff5ea3a95 in g_main_dispatch (context=0x6752e0) at gmain.c:2715
#22 g_main_context_dispatch (context=context@entry=0x6752e0) at gmain.c:3219
#23 0x00007ffff5ea3dc8 in g_main_context_iterate (context=context@entry=
    0x6752e0, block=block@entry=1, dispatch=dispatch@entry=1, 
    self=<optimized out>) at gmain.c:3290
#24 0x00007ffff5ea3e84 in g_main_context_iteration (context=0x6752e0, 
    context@entry=0x0, may_block=may_block@entry=1) at gmain.c:3351
Python Exception <type 'exceptions.ValueError'> Variable 'g_quarks' not found.: 
#25 0x00007ffff646872c in g_application_run (application=, argc=argc@entry=1, 
    argv=argv@entry=0x7fffffffe328) at gapplication.c:1620
#26 0x0000000000410a96 in main (argc=1, argv=0x7fffffffe328) at main.c:27
Comment 1 David Zeuthen 2012-09-28 10:39:42 EDT
Looks like a pango bug to me.
Comment 2 Matthias Clasen 2012-10-04 23:01:48 EDT
It is fixed in pango 1.32.1, available in updates-testing

Note You need to log in before you can comment on or make changes to this bug.