Bug 861408 - Cannot stop, restart or delete state "New" application
Cannot stop, restart or delete state "New" application
Status: CLOSED DUPLICATE of bug 863383
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity medium
: beta4
: ---
Assigned To: Jan Provaznik
Rehana
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 09:45 EDT by Aaron Weitekamp
Modified: 2012-10-08 13:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-08 13:42:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ui screencap: cannot delete new application (214.67 KB, image/jpeg)
2012-09-28 09:45 EDT, Aaron Weitekamp
no flags Details
aeolus-debug logs (5.47 MB, application/x-gzip)
2012-09-28 09:48 EDT, Aaron Weitekamp
no flags Details
screencap: stop and restart buttons not disabled as expected (71.99 KB, image/png)
2012-09-28 10:00 EDT, Aaron Weitekamp
no flags Details

  None (edit)
Description Aaron Weitekamp 2012-09-28 09:45:55 EDT
Created attachment 618584 [details]
ui screencap: cannot delete new application

Description of problem:
I launched 5 applications consecutively. They are stuck in state "new". While that may be a bug itself, there is no way for me to resolve this state. I cannot stop, restart or delete these applications.

Version-Release number of selected component (if applicable):
1.1
[root@qeblade40 ~]# rpm -qa |grep aeolus
aeolus-conductor-0.13.14-1.el6cf.noarch
aeolus-configure-2.8.7-1.el6cf.noarch
aeolus-all-0.13.14-1.el6cf.noarch
aeolus-conductor-doc-0.13.14-1.el6cf.noarch
rubygem-aeolus-cli-0.7.2-1.el6cf.noarch
aeolus-conductor-daemons-0.13.14-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch

How reproducible:


Steps to Reproduce:
1. Launch application(s) so they are in state "new" or starting up
2. Try to restart, stop or delete the application
  
Actual results:
Cannot resolve an app from new state.

Expected results:
If an app is hung for some reason I should be able to at least send a stop and restart request. There may be orphan issues with deleting a running application. If not, delete should be an option.

Error message displayed:
"""
The Application CF-Tools-on-6Server-x86-64 can not be deleted because following instances can not be stopped:

Errors
The instance CF-Tools-on-6Server-x86-64/rhel-x86-64-6Server-cf-tools is in state new.
"""
Comment 1 Aaron Weitekamp 2012-09-28 09:48:25 EDT
Created attachment 618585 [details]
aeolus-debug logs
Comment 2 Aaron Weitekamp 2012-09-28 10:00:44 EDT
Created attachment 618612 [details]
screencap: stop and restart buttons not disabled as expected

BZ won't allow me to link to 859954 (?) but this is related: https://bugzilla.redhat.com/show_bug.cgi?id=859954

The stop and restart buttons are clickable but do nothing. They are not clearly disabled. See attached screencap.
Comment 4 Jan Provaznik 2012-10-02 13:42:28 EDT
Only reason when instances stay in 'new' stay is when delayed_job service is not running/doesn't work properly. Can you please double-check that conductor-delayed_job service is running?
Comment 5 Mike Orazi 2012-10-05 10:00:11 EDT
This seems to be not directly reproducible as described.  If you agree that's the case, please close this as not a but or provide additional steps to help us clarify.
Comment 6 Dave Johnson 2012-10-08 13:42:07 EDT

*** This bug has been marked as a duplicate of bug 863383 ***

Note You need to log in before you can comment on or make changes to this bug.