Bug 861466 - Problem to install Evolution Exchange - Dependencies are broken
Problem to install Evolution Exchange - Dependencies are broken
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution-exchange (Show other bugs)
18
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 13:33 EDT by Fabiano Fidêncio
Modified: 2012-09-30 23:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-29 00:42:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabiano Fidêncio 2012-09-28 13:33:50 EDT
Description of problem:
Dependencies are broken to install evolution-exchange package in f18

Version-Release number of selected component (if applicable):
evolution-exchange-3.5.2-1.fc18.x86_64

How reproducible:
yum install evolution-exchange

Actual results:
fidencio@localhost ~/src/qemu $ sudo yum -y install evolution-exchange.x86_64 
[sudo] password for fidencio: 
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package evolution-exchange.x86_64 0:3.5.2-1.fc18 will be installed
--> Processing Dependency: libedataserverui-3.0.so.3()(64bit) for package: evolution-exchange-3.5.2-1.fc18.x86_64
--> Processing Dependency: libedataserver-1.2.so.16()(64bit) for package: evolution-exchange-3.5.2-1.fc18.x86_64
--> Processing Dependency: libedata-cal-1.2.so.17()(64bit) for package: evolution-exchange-3.5.2-1.fc18.x86_64
--> Processing Dependency: libedata-book-1.2.so.14()(64bit) for package: evolution-exchange-3.5.2-1.fc18.x86_64
--> Processing Dependency: libecal-1.2.so.12()(64bit) for package: evolution-exchange-3.5.2-1.fc18.x86_64
--> Processing Dependency: libebook-1.2.so.13()(64bit) for package: evolution-exchange-3.5.2-1.fc18.x86_64
--> Processing Dependency: libebackend-1.2.so.3()(64bit) for package: evolution-exchange-3.5.2-1.fc18.x86_64
--> Processing Dependency: libcamel-1.2.so.36()(64bit) for package: evolution-exchange-3.5.2-1.fc18.x86_64
--> Finished Dependency Resolution
Error: Package: evolution-exchange-3.5.2-1.fc18.x86_64 (fedora)
           Requires: libebook-1.2.so.13()(64bit)
Error: Package: evolution-exchange-3.5.2-1.fc18.x86_64 (fedora)
           Requires: libedataserver-1.2.so.16()(64bit)
Error: Package: evolution-exchange-3.5.2-1.fc18.x86_64 (fedora)
           Requires: libecal-1.2.so.12()(64bit)
Error: Package: evolution-exchange-3.5.2-1.fc18.x86_64 (fedora)
           Requires: libedataserverui-3.0.so.3()(64bit)
Error: Package: evolution-exchange-3.5.2-1.fc18.x86_64 (fedora)
           Requires: libcamel-1.2.so.36()(64bit)
Error: Package: evolution-exchange-3.5.2-1.fc18.x86_64 (fedora)
           Requires: libedata-cal-1.2.so.17()(64bit)
Error: Package: evolution-exchange-3.5.2-1.fc18.x86_64 (fedora)
           Requires: libedata-book-1.2.so.14()(64bit)
Error: Package: evolution-exchange-3.5.2-1.fc18.x86_64 (fedora)
           Requires: libebackend-1.2.so.3()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 1 Matthew Barnes 2012-09-29 00:42:53 EDT
evolution-exchange is retired in Fedora 18.

https://admin.fedoraproject.org/pkgdb/acls/name/evolution-exchange#f18

You can use evolution-mapi or evolution-ews to connect to Exchange servers.
Comment 2 Fabiano Fidêncio 2012-09-30 23:35:03 EDT
(In reply to comment #1)
> evolution-exchange is retired in Fedora 18.
> 
> https://admin.fedoraproject.org/pkgdb/acls/name/evolution-exchange#f18
> 
> You can use evolution-mapi or evolution-ews to connect to Exchange servers.

evolution-exchange was the only way I got to connect on older Exchanges (2000) that uses Outlook Web Access :(

Note You need to log in before you can comment on or make changes to this bug.