Bug 861470 - JBoss Enterprise Application Platform - ELS (jbappplatform-4.2.0) 192.pem product certs are missing from subscription-manager-migration-data
JBoss Enterprise Application Platform - ELS (jbappplatform-4.2.0) 192.pem pro...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager-migration-data (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Alex Wood
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-09-28 13:54 EDT by John Sefler
Modified: 2013-01-08 02:28 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 02:28:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-09-28 13:54:37 EDT
Description of problem:
Looks like a new product was mapped in the product-baseline.json and now subscription-manager-migration-data needs to be re-generated.

> java.lang.AssertionError: CDN Product Baseline RHN Channel 'jbappplatform-4.2-els-x86_64-server-5-rpm' is accounted for in the subscription-manager-migration-data file '/usr/share/rhsm/product/RHEL-5/channel-cert-mapping.txt'. expected:<true> but was:<false>
> java.lang.AssertionError: CDN Product Baseline RHN Channel 'jbappplatform-4.2-els-i386-server-5-rpm' is accounted for in the subscription-manager-migration-data file '/usr/share/rhsm/product/RHEL-5/channel-cert-mapping.txt'. expected:<true> but was:<false>


Version-Release number of selected component (if applicable):
[root@rhsm-accept-rhel5 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-1.11.2.4-1.el5

How reproducible:


Steps to Reproduce:
[root@rhsm-accept-rhel5 ~]# rpm -ql subscription-manager-migration-data | grep 192.pem
[root@rhsm-accept-rhel5 ~]#

^^^ EXPECTED GREP TO FIND 
ELS-JBEAP-i386-b6f4ebfa7028-192.pem
ELS-JBEAP-x86_64-45e5593a0c35-192.pem


[root@rhsm-accept-rhel5 ~]# grep jbappplatform-4.2-els /usr/share/rhsm/product/RHEL-5/channel-cert-mapping.txt
[root@rhsm-accept-rhel5 ~]# 

^^^ EXPECTED GREP TO FIND A MAPPING FOR CHANNELS MATCHING jbappplatform-4.2-els*
Comment 1 RHEL Product and Program Management 2012-09-28 14:09:39 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Alex Wood 2012-10-01 16:43:49 EDT
commit 060403e39fff2aeec6815351a40204a75d9dcb34
Author: Alex Wood <awood@redhat.com>
Date:   Mon Oct 1 14:04:03 2012 -0400

    861470: Add mapping and certificates for ELS-JBEAP.
Comment 4 John Sefler 2012-10-08 17:03:13 EDT
Verifying Version...
[root@jsefler-rhel59 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-1.11.2.6-1.el5


[root@jsefler-rhel59 ~]# rpm -ql subscription-manager-migration-data | grep 192.pem
/usr/share/rhsm/product/RHEL-5/ELS-JBEAP-i386-b6f4ebfa7028-192.pem
/usr/share/rhsm/product/RHEL-5/ELS-JBEAP-x86_64-45e5593a0c35-192.pem

[root@jsefler-rhel59 ~]# grep jbappplatform-4.2-els /usr/share/rhsm/product/RHEL-5/channel-cert-mapping.txt
jbappplatform-4.2-els-i386-server-5-rpm: ELS-JBEAP-i386-b6f4ebfa7028-192.pem
jbappplatform-4.2-els-x86_64-server-5-rpm: ELS-JBEAP-x86_64-45e5593a0c35-192.pem


Moving to VERIFIED
Comment 6 errata-xmlrpc 2013-01-08 02:28:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0055.html

Note You need to log in before you can comment on or make changes to this bug.