Bug 861473 - alacarte wont starts
alacarte wont starts
Status: CLOSED DUPLICATE of bug 831844
Product: Fedora
Classification: Fedora
Component: alacarte (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jasper St. Pierre
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 14:06 EDT by Ivan Romanov
Modified: 2014-08-26 22:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-28 16:22:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Romanov 2012-09-28 14:06:44 EDT
I use Fedora 17 with XFCE. When i'm trying to start alacarte never happens. Terminal output:

$ alacarte
Traceback (most recent call last):
  File "/usr/bin/alacarte", line 36, in <module>
    main()
  File "/usr/bin/alacarte", line 33, in main
    app.run()
  File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 64, in run
    self.loadMenus()
  File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 203, in loadMenus
    self.on_menu_tree_cursor_changed(menu_tree)
  File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 354, in on_menu_tree_cursor_changed
    self.loadItems(self.menu_store[menu_path][2], menu_path)
  File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 217, in loadItems
    for item, show in self.editor.getItems(menu):
  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 145, in getItems
    item = item_iter.get_separator()
AttributeError: 'TreeIter' object has no attribute 'get_separator'

$ rpm -q alacarte pygtk2
alacarte-0.13.4-4.fc17.noarch
pygtk2-2.24.0-4.fc17.i686

I've seen pygtk documentation. In really TreeIter has no get_separator function
Comment 1 Jasper St. Pierre 2012-09-28 16:22:06 EDT

*** This bug has been marked as a duplicate of bug 831844 ***

Note You need to log in before you can comment on or make changes to this bug.