Bug 861475 - orphan remove --type rpm doesn't seem to remove orphaned rpm
orphan remove --type rpm doesn't seem to remove orphaned rpm
Status: CLOSED WORKSFORME
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
Master
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Sprint 41
Assigned To: Michael Hrivnak
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 14:16 EDT by Preethi Thomas
Modified: 2013-09-09 12:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-16 06:45:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2012-09-28 14:16:56 EDT
Description of problem:

orphan remove --type rpm doesn't seem to remove orphaned rpm

Version-Release number of selected component (if applicable):

[root@pulp-master ~]# rpm -q pulp-rpm-server
pulp-rpm-server-0.0.328-1.fc17.noarch
[root@pulp-master ~]# 

How reproducible:


Steps to Reproduce:
1. create a and sync a repo
2. run orphan remove --type rpm
3.
  
Actual results:
[root@pulp-master ~]# pulp-admin repo delete --repo-id pulp
Repository [pulp] successfully deleted

[root@pulp-master ~]# pulp-admin orphan list
Description:             pulp
Display Order:           0
Id:                      3a63fff6-cc74-4007-b1b5-50d5bbe25015
Name:                    pulp
Packagegroupids:         None
Repo Id:                 pulp
Translated Description:  
Translated Name:         


[root@pulp-master ~]# pulp-admin orphan remove --type rpm
Request accepted

check status of task 9b3e58de-0993-11e2-afd9-54520075d18e with "pulp-admin tasks
details"
[root@pulp-master ~]# pulp-admin orphan list
Description:             pulp
Display Order:           0
Id:                      3a63fff6-cc74-4007-b1b5-50d5bbe25015
Name:                    pulp
Packagegroupids:         None
Repo Id:                 pulp
Translated Description:  
Translated Name:         




Expected results:


Additional info:
Comment 1 Michael Hrivnak 2012-10-15 13:58:40 EDT
I am not able to reproduce this. Here are my steps:

1) pulp-admin rpm repo create --repo-id=pulp2 --feed=http://repos.fedorapeople.org/repos/pulp/pulp/v2/testing/fedora-17/x86_64/

2) pulp-admin rpm repo sync run --repo-id=pulp2

3) pulp-admin rpm repo delete --repo-id=pulp2

4) pulp-admin orphan list --type=rpm -s
 # should show 41 orphan RPMs.

5) pulp-admin orphan remove --type rpm

6) pulp-admin orphan list --type=rpm -s
 # now shows 0 RPM orphans

Can you confirm that the orphans you saw were of type RPM? And/or, can you try the above steps and see if that works for you?
Comment 2 Preethi Thomas 2012-10-16 06:45:44 EDT
Tested this in build 331  and This seems to be working fine. Closing

Note You need to log in before you can comment on or make changes to this bug.