Bug 861483 - default user quota setting
default user quota setting
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity medium
: beta4
: ---
Assigned To: Scott Seago
Dave Johnson
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 15:27 EDT by Dave Johnson
Modified: 2012-12-04 10:22 EST (History)
7 users (show)

See Also:
Fixed In Version: aeolus-conductor-0.13.18-1.el6cf
Doc Type: Bug Fix
Doc Text:
On the settings tab the 'Self-sevice user quota' field serves as the default quota setting for self-service users. This is not supported by CloudForms Cloud Engine. This fix changes the use of the field for default quota usage and adds quota inheritance for LDAP users.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:22:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Johnson 2012-09-28 15:27:24 EDT
Description of problem:
===========================
On the settings tab, there is a 'self-sevice user quota' field which serves as the default quota setting for self service users which CFCE does not have support for.  Originally QE wrote up bug 861099 to get the entire tab removed however in talking with dev, updating this field to be used for ldap users would be more appropriate.

Two things
1) Fix the label of the field
2) Get ldap users to inherit this quota
Comment 2 Scott Seago 2012-10-04 11:09:28 EDT
Patch on list:


From: Scott Seago <sseago@redhat.com>
Date: Thu, 4 Oct 2012 11:02:21 -0400
Subject: [PATCH conductor] bug 861483: Fix default quota

https://bugzilla.redhat.com/show_bug.cgi?id=861483

Default quota now shows itself in two ways:
1) for admin-created users, the default quota is set as the default
 for the user quota in the new user form. It can still be edited
 before submitting, of course.
2) For ldap users, when a new conductor user is created, we now
   create the user with a quota value taken from the default.
Comment 3 Tzu-Mainn Chen 2012-10-04 15:30:29 EDT
ACK'd and pushed to master; doesn't apply to 1.1:

commit 6917a508cc3c2a3e5e85fbc21e95e320306044e9
Author: Scott Seago <sseago@redhat.com>
Date:   Thu Oct 4 14:41:17 2012 -0400

    https://bugzilla.redhat.com/show_bug.cgi?id=861483
    
    Default quota now shows itself in two ways:
    1) for admin-created users, the default quota is set as the default
     for the user quota in the new user form. It can still be edited
     before submitting, of course.
    2) For ldap users, when a new conductor user is created, we now
       create the user with a quota value taken from the default.
    
    Signed-off-by: Tzu-Mainn Chen <tzumainn@redhat.com>
Comment 4 Scott Seago 2012-10-04 17:21:44 EDT
on 1.1 at: 

commit aec905255a1c3c99328ef0735e28f88de38512fe

and on master at:
6917a508cc3c2a3e5e85fbc21e95e320306044e9
Comment 6 Shveta 2012-10-15 15:01:46 EDT
Set the default user quota to 5 .
Add a new user in conductor (database mode) , by default user gets the quota value set to 5.

Ldap mode , any existing or new ldap user gets the ldap value set to 5 by default.

rpm -qa|grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.13.18-1.el6cf.noarch
rubygem-aeolus-cli-0.7.4-1.el6cf.noarch
aeolus-conductor-doc-0.13.18-1.el6cf.noarch
aeolus-all-0.13.18-1.el6cf.noarch
aeolus-configure-2.8.9-1.el6cf.noarch
aeolus-conductor-0.13.18-1.el6cf.noarch
Comment 8 errata-xmlrpc 2012-12-04 10:22:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.