Bug 861492 - live migration fails to migrate iptable rules to new host
live migration fails to migrate iptable rules to new host
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
1.0 (Essex)
x86_64 Linux
unspecified Severity unspecified
: snapshot5
: 2.1
Assigned To: Nikola Dipanov
Yaniv Kaul
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 15:53 EDT by Dan Yocum
Modified: 2016-04-22 01:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-11 12:49:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dan Yocum 2012-09-28 15:53:40 EDT
Description of problem:

When migrating a VM from one compute node to another, the IP tables are not torn down on the old host and moved to the new one.   I'm using the flatDHCP network manager.

Version-Release number of selected component (if applicable):

Essex

How reproducible:

every

Steps to Reproduce:
1. start a VM with a floating public IP
2. migrate the VM to a new compute node
3. look at iptables-save output on both nodes and see that the rules did not migrate
  
Actual results:

iptable rules for floating public IP remains on compute node w/o VM

Expected results:

iptable rules for floating public IP should be on the new compute node hosting the VM

Additional info:
Comment 5 Nikola Dipanov 2013-03-11 12:49:08 EDT
Since there was no info provided on this bug, and nothing similar was reported against folsom, I will close this as not a bug.

Feel free to reopen once you are able to provide more info.

Note You need to log in before you can comment on or make changes to this bug.