Bug 861515 - kernel 3.6 fails to boot. apci=off works, acpi=ht does not
kernel 3.6 fails to boot. apci=off works, acpi=ht does not
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 17:50 EDT by Thomas H.P. Andersen
Modified: 2012-10-03 21:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-03 21:10:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci (from 3.6.0-0.rc6.git0.2) (23.43 KB, application/octet-stream)
2012-09-28 17:56 EDT, Thomas H.P. Andersen
no flags Details
dmidecode (from 3.6.0-0.rc6.git0.2) (7.18 KB, application/octet-stream)
2012-09-28 17:56 EDT, Thomas H.P. Andersen
no flags Details
dmesg (from 3.6.0-0.rc6.git0.2) (48.63 KB, application/octet-stream)
2012-09-28 17:57 EDT, Thomas H.P. Andersen
no flags Details

  None (edit)
Description Thomas H.P. Andersen 2012-09-28 17:50:57 EDT
Description of problem:

The kernel hangs when trying to boot the 3.6 version. Latest 3.5 works.
Booting with acpi=off works, but acpi=ht does not.

Version-Release number of selected component (if applicable):
I have tried all the kernels since the alpha (latest test with 3.6.0-0.rc7.git1.4.fc18.x86_64)

How reproducible:
Boot any 3.6 kernel on this hardware.
  
Actual results:
The kernel hangs after "Loading initial ramdisk...".

Expected results:
A booting kernel with acpi turned on

Additional info:
I tried the suggestions given on the wiki:
http://fedoraproject.org/wiki/Common_kernel_problems#Crashes.2FHangs

acpi=off makes it boot. acpi=ht does not boot. Found this comment somewhere:
"This disables all of ACPI except just enough to enable Hyper Threading. If acpi=off works and acpi=ht fails, then the issue is in the ACPI table parsing code itself, or perhaps the SMP code."
Comment 1 Thomas H.P. Andersen 2012-09-28 17:56:13 EDT
Created attachment 618775 [details]
lspci (from 3.6.0-0.rc6.git0.2)
Comment 2 Thomas H.P. Andersen 2012-09-28 17:56:54 EDT
Created attachment 618776 [details]
dmidecode (from 3.6.0-0.rc6.git0.2)
Comment 3 Thomas H.P. Andersen 2012-09-28 17:57:32 EDT
Created attachment 618777 [details]
dmesg (from 3.6.0-0.rc6.git0.2)
Comment 4 Thomas H.P. Andersen 2012-10-03 21:10:23 EDT
With the newer kernels (3.6.0-1) the problem is gone. I do get a lot of warnings and errs in dmesg but I can live with that.

Closing.

Note You need to log in before you can comment on or make changes to this bug.