Bug 861531 - Restore GPL licensing option
Restore GPL licensing option
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 21:43 EDT by luke-jr+redhatbugs
Modified: 2012-10-17 05:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-17 05:39:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description luke-jr+redhatbugs 2012-09-28 21:43:43 EDT
Description of problem: The SIL "Open Font License" is not really free. Previous versions of Liberation fotns were available under the free GPL-2 (with exceptions) license.


Version-Release number of selected component (if applicable): 2.0


How reproducible: Always.


Steps to Reproduce:
1. Consider the freedom to sell the font by itself.
2. Realize the OFL license forbids it.
3. Since freedom to sell is forbidden, such a license is non-free.
  
Actual results: Liberation fonts 2.0 are non-free.


Expected results: Liberation fonts 2.0 are free, like earlier versions.


Additional info: Licenses do not need to be exclusive. I suggest giving the choice of either license.
Comment 1 Jens Petersen 2012-10-01 03:11:24 EDT
(In reply to comment #0)
> Description of problem: The SIL "Open Font License" is not really free.

It is according to both the Fedora and GNU projects.

> 1. Consider the freedom to sell the font by itself.
> 2. Realize the OFL license forbids it.
> 3. Since freedom to sell is forbidden, such a license is non-free.

True this is a small limitation of the OFL.
Why do you want to sell a copy of Liberation by itself?
Comment 2 Pravin Satpute 2012-10-01 03:14:24 EDT
One more point, we still have liberation-fonts-1.07.2.tar.gz available in upstream under the Old license.
Comment 3 luke-jr+redhatbugs 2012-10-01 06:06:02 EDT
I have no particular reason to sell Liberation by itself, nor to sell the majority of software I use period. I do, however, have interest in only running (truly) free software so I don't have to worry about these things.

The GNU project considers OFL to be "free" because they consider it acceptable to use a loophole and bundle it with a dummy program. I consider loopholes to be bad faith, and I have doubts that it would fly in court if it ever came down to that.

I do still have the older Liberation version installed, but truly free fonts seem rare and I thought the freedom was the primary motivation behind the Liberation font family. It seems a shame to lose that.
Comment 4 Jens Petersen 2012-10-02 00:32:46 EDT
Hi Luke,

While I take your point - and agree this restriction in the SIL OFL
license seems unnecessary (dunno if it was added by SIL as some
kind of protection against other profiting from their fonts?)
but as you say the "loophole" makes it pretty trivial to circumvent anyway.

But please realise that the actual old Liberation fonts licence
is rather more complicated than just GPL + licensing exception.
There are some additional terms unfortunately due to the original
arrangement made with Ascender when Red Hat bought the fonts
that have caused quite a lot of confusion in the past about the status of
Liberation license.  So to me OFL is still a big improvement
over the previous license situation.  Anyway the Liberation 2 rebase with
croscore fonts means that the license has to be OFL.

There is still some discussion ongoing about what to do with the old
Liberation fonts in Fedora.
Comment 5 Pravin Satpute 2012-10-09 04:28:26 EDT
I respect your point of view. But in present situation it is not possible to Restore GPL. Since community will miss lots of Enhancement like extended coverage, better hinting. And i am sure we are moving to better license than earlier.

There is tweak though as said here.

http://www.gnu.org/licenses/license-list.html#SILOFL

"The Open Font License (including its original release, version 1.0) is a free copyleft license for fonts. Its only unusual requirement is that fonts be distributed with some computer program, rather than alone. Since a simple Hello World program will satisfy the requirement, it is harmless. Neither we nor SIL recommend the use of this license for anything other than fonts."
Comment 6 Pravin Satpute 2012-10-17 05:39:20 EDT
closing this, please reopen if required.

Note You need to log in before you can comment on or make changes to this bug.