Bug 861543 - [US2814][US2816][fork] '-l' and '-p' and '-d' and '--config' and '-t' global options can not work.
[US2814][US2816][fork] '-l' and '-p' and '-d' and '--config' and '-t' global ...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-29 02:03 EDT by Wei Sun
Modified: 2015-05-14 22:06 EDT (History)
3 users (show)

See Also:
Fixed In Version: fork_ami_US2597_US2599_US2813_US2817_US2872_US2816_US2814_194
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:48:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wei Sun 2012-09-29 02:03:40 EDT
Description of problem:
 Run "rhc alias add -h",could get global options,but can not work well while using these options,like "rhc alias add diytest ditalias -l wsun@redhat.com",will prompt invalid option: -l
 
Version-Release number of selected component (if applicable):
server:fork_ami_US2597_US2599_US2813_US2817_US2872_186 (ami-19f04d70)
client:building  rhc package using repo git@github.com:calfonso/rhc.git

How reproducible:
always

Steps to Reproduce:
1.create an app
2.add alias to app with these options
rhc alias add diytest ditalias -l wsun@redhat.com

Actual results:

[sunwei@dhcp-8-229 dev]$ rhc alias add diytest ditalias -l wsun@redhat.com
invalid option: -l

Usage: rhc alias add <application> <alias> [--namespace namespace]

Add a custom domain name for the application

Options for alias add
  -n, --namespace namespace Namespace of your application

Global Options
  -l, --rhlogin login       OpenShift login
  -p, --password password   OpenShift password
  -d, --debug               Turn on debugging
  --noprompt                Do not ask for input
  --config FILE             Path of a different config file
  -h, --help                Display help documentation
  -v, --version             Display version information
  -t, --trace               Display backtrace when an error occurs

Expected results:

These options can work well.

Additional info:

use master rhc 0.99.3 ,can work well

[sunwei@dhcp-8-229 client]$ rhc app add-alias -a jbosstest --alias jbalias -l wsun@redhat.com
Password: ******


RESULT:
Success
Comment 1 John (J5) Palmieri 2012-10-01 12:40:40 EDT
Looks like this works in my command-merge-master branch.  I have just merged chris' alias branch.
Comment 2 Chandrika Gole 2012-10-02 19:24:43 EDT
verified on AMI: fork_ami_US2597_US2599_US2813_US2817_US2872_US2816_US2814_202 (ami-7b40fd12)
Comment 3 Chandrika Gole 2012-10-02 19:27:57 EDT
[root@ip-10-145-185-183 ~]# rhc alias add  jb  jbalias1   -l cgole@redhat.com 
Password: 


RESULT:
Application event 'add-alias' successful

Note You need to log in before you can comment on or make changes to this bug.