Bug 861563 - Sometimes stop virt-who failed via command "service virt-who restart" in ESX mode
Sometimes stop virt-who failed via command "service virt-who restart" in ESX ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-who (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Radek Novacek
Entitlement Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-29 03:57 EDT by lzhuang
Modified: 2016-11-30 19:31 EST (History)
10 users (show)

See Also:
Fixed In Version: virt-who-0.7-9.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 02:36:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lzhuang 2012-09-29 03:57:12 EDT
Description of problem:
If running command "service virt-who restart" many times, and the interval is very short, stop virt-who service will fail, but start the service successfully, and there will be many virt-who processes running. 

Version-Release number of selected component (if applicable):
subscription-manager-gui-1.0.20-1.el5
subscription-manager-1.0.20-1.el5
subscription-manager-firstboot-1.0.20-1.el5
python-rhsm-1.0.9-1.el5
virt-who-0.7-8.el5

How reproducible:
100%

Steps to Reproduce:
1. restart virt-who service many times with short interval of each operation:
[root@rhel59 ~]# service virt-who restart
Stopping virt-who:                                         [  OK  ]
Starting virt-who:                                         [  OK  ]
[root@rhel59 ~]# service virt-who restart
Stopping virt-who:                                         [FAILED]
Starting virt-who:                                         [  OK  ]
[root@rhel59 ~]# service virt-who restart
Stopping virt-who:                                         [FAILED]
Starting virt-who:                                         [  OK  ]
[root@rhel59 ~]# service virt-who restart
Stopping virt-who:                                         [FAILED]
Starting virt-who:                                         [  OK  ]
[root@rhel59 ~]# service virt-who restart
Stopping virt-who:                                         [FAILED]
Starting virt-who:                                         [  OK  ]
2. check the virt-who process:
[root@rhel59 ~]# ps -ef|grep virt-who
root     21128     1 67 03:52 ?        00:00:06 /usr/bin/python /usr/share/virt-who/virt-who.py
root     21144     1 47 03:52 ?        00:00:03 /usr/bin/python /usr/share/virt-who/virt-who.py
root     21160     1 38 03:52 ?        00:00:02 /usr/bin/python /usr/share/virt-who/virt-who.py
root     21176     1 45 03:52 ?        00:00:02 /usr/bin/python /usr/share/virt-who/virt-who.py
root     21192     1 27 03:52 ?        00:00:01 /usr/bin/python /usr/share/virt-who/virt-who.py
root     21196 20194  0 03:52 pts/3    00:00:00 grep virt-who

  
Actual results:
1. Stop virt-who service will fail, but start the service succeed
2. There are many virt-who processes running

Expected results:
If failed to stop virt-who service, it should not start a new one, and there should be only 1 process running in the system.


Additional info:
Comment 1 RHEL Product and Program Management 2012-09-29 04:08:23 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Radek Novacek 2012-10-04 06:30:58 EDT
This bug has been fixed in virt-who-0.7-9.el5.
Comment 5 lzhuang 2012-10-07 22:15:44 EDT
This bug has been verified, and the result is PASS.

Verifying version:
[root@rhel59 ~]# rpm -qa|grep virt-who
virt-who-0.7-9.el5

Steps and results:
1. restart virt-who service, and it will succeed every time:
[root@rhel59 ~]# service virt-who restart
Stopping virt-who:                                         [  OK  ]
Starting virt-who:                                         [  OK  ]
[root@rhel59 ~]# service virt-who restart
Stopping virt-who:                                         [  OK  ]
Starting virt-who:                                         [  OK  ]
[root@rhel59 ~]# service virt-who restart
Stopping virt-who:                                         [  OK  ]
Starting virt-who:                                         [  OK  ]
[root@rhel59 ~]# service virt-who restart
Stopping virt-who:                                         [  OK  ]
Starting virt-who:                                         [  OK  ]
2. check process of virt-who running in system, there's only 1 virt-who process running:
[root@rhel59 ~]# ps -ef|grep virt-who
root     12890     1 95 22:04 ?        00:00:04 /usr/bin/python /usr/share/virt-who/virt-who.py
root     12893 12680  0 22:04 pts/1    00:00:00 grep virt-who
Comment 6 Hui Wang 2012-10-07 22:20:10 EDT
Moving to Verified according comment5
Comment 8 errata-xmlrpc 2013-01-08 02:36:32 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0072.html

Note You need to log in before you can comment on or make changes to this bug.