Bug 861587 - [fork]Can't support hot_deploy in fork_ami_origin-selinux_187
[fork]Can't support hot_deploy in fork_ami_origin-selinux_187
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Rob Millner
libra bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-29 06:03 EDT by Rony Gong
Modified: 2015-05-14 19:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:49:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rony Gong 2012-09-29 06:03:46 EDT
Description of problem:
touch the file hot_deploy in .openshift/markers, after git push, all pid changed, so didn't support hot_deploy in this fork,
I checked app like ruby, perl, php etc.

Version-Release number of selected component (if applicable):
fork_ami_origin-selinux_187

How reproducible:
always

Steps to Reproduce:
1.Create application like perl, php
2.Then cd app_dir, touch .openshift/markers/hot_deploy
3.git push
  
Actual results:
    git config --global user.name "Your Name"
    git config --global user.email you@example.com
If the identity used for this commit is wrong, you can fix it with:
    git commit --amend --author='Your Name <you@example.com>'
 1 files changed, 1 insertions(+), 1 deletions(-)
Counting objects: 7, done.
Delta compression using up to 8 threads.
Compressing objects: 100% (4/4), done.
Writing objects: 100% (4/4), 336 bytes, done.
Total 4 (delta 3), reused 0 (delta 0)
remote: restart_on_add=false
remote: Stopping application...
remote: Waiting for stop to finish
remote: Done
remote: restart_on_add=false
remote: ~/git/qperl.git ~/git/qperl.git
remote: ~/git/qperl.git
remote: Running .openshift/action_hooks/pre_build
remote: Running .openshift/action_hooks/build
remote: Running .openshift/action_hooks/deploy
remote: hot_deploy_added=false
remote: Starting application...
remote: Done
remote: Running .openshift/action_hooks/post_deploy
To ssh://5411598620334075a8dda7268b91327b@qperl-qgong13.dev.rhcloud.com/~/git/qperl.git/
   b5d4bbc..25b690d  master -> master
the app restart since the pid changed


Expected results:
supported hot_deploy, pid not changed
Comment 1 Rob Millner 2012-10-26 17:31:26 EDT
Hot deploy is working on latest devenv.

$ rhc app create -a rmtest -t php-5.3

...

Successfully created application: rmtest

$ ssh c8bc5bce74984a3d96a8a419f2ce1aa4@rmtest-rmillner0117.dev.rhcloud.com ps

  PID TTY          TIME CMD
10112 ?        00:00:00 httpd
10114 ?        00:00:00 rotatelogs
10115 ?        00:00:00 rotatelogs
10123 ?        00:00:00 httpd
10527 ?        00:00:00 sshd
10528 ?        00:00:00 ps

$ cd rmtest/

$ touch .openshift/markers/hot_deploy

$ git add .openshift/markers/hot_deploy

$ git commit -a -m 'new hot deploy marker'

$ git push
Counting objects: 7, done.
Delta compression using up to 2 threads.
Compressing objects: 100% (4/4), done.
Writing objects: 100% (4/4), 390 bytes, done.
Total 4 (delta 2), reused 0 (delta 0)
remote: restart_on_add=false
remote: Will add new hot deploy marker
remote: App will not be stopped due to presence of hot_deploy marker
remote: restart_on_add=false
remote: ~/git/rmtest.git ~/git/rmtest.git
remote: ~/git/rmtest.git
remote: Running .openshift/action_hooks/pre_build
remote: Running .openshift/action_hooks/build
remote: Running .openshift/action_hooks/deploy
remote: hot_deploy_added=false
remote: App will not be started due to presence of hot_deploy marker
remote: Running .openshift/action_hooks/post_deploy
To ssh://c8bc5bce74984a3d96a8a419f2ce1aa4@rmtest-rmillner0117.dev.rhcloud.com/~/git/rmtest.git/
   f9fa15d..596aaab  master -> master

$ ssh c8bc5bce74984a3d96a8a419f2ce1aa4@rmtest-rmillner0117.dev.rhcloud.com ps
  PID TTY          TIME CMD
10112 ?        00:00:00 httpd
10114 ?        00:00:00 rotatelogs
10115 ?        00:00:00 rotatelogs
10123 ?        00:00:00 httpd
10940 ?        00:00:00 sshd
10941 ?        00:00:00 ps
Comment 2 Rony Gong 2012-10-29 06:03:00 EDT
Verified on devenv_2397
Steps:
1.Create php,ruby app and enable hot_deploy
before git push hot_deploy:
[qphp-qgong3.dev.rhcloud.com ~]\> ps -aux
Warning: bad syntax, perhaps a bogus '-'? See /usr/share/doc/procps-3.2.8/FAQ
USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
520      11813  0.0  0.3 363064 12228 ?        Ss   03:10   0:00 /usr/sbin/httpd -C Include /var/lib/openshift/f7f2ea44d1f44085a4b8c7409a807971//php-5.3
520      11815  0.0  0.0  32200  1196 ?        S    03:10   0:00 /usr/sbin/rotatelogs /var/lib/openshift/f7f2ea44d1f44085a4b8c7409a807971/php-5.3/logs/e
520      11816  0.0  0.0  32200  1076 ?        S    03:10   0:00 /usr/sbin/rotatelogs /var/lib/openshift/f7f2ea44d1f44085a4b8c7409a807971/php-5.3/logs/a
520      11835  0.0  0.1 363064  5944 ?        S    03:10   0:00 /usr/sbin/httpd -C Include /var/lib/openshift/f7f2ea44d1f44085a4b8c7409a807971//php-5.3
520      12631  0.2  0.0  95772  1812 ?        S    03:12   0:00 sshd: f7f2ea44d1f44085a4b8c7409a807971@pts/0
520      12720  0.1  0.0 108428  2088 ?        Ss   03:12   0:00 /bin/bash --init-file /usr/bin/rhcsh -i
520      12817  0.0  0.0 110228  1168 ?        R+   03:12   0:00 ps -aux


after git push hot_deploy:
[qphp-qgong3.dev.rhcloud.com ~]\> ps -aux
Warning: bad syntax, perhaps a bogus '-'? See /usr/share/doc/procps-3.2.8/FAQ
USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
520      11813  0.0  0.3 363064 12228 ?        Ss   03:10   0:00 /usr/sbin/httpd -C Include /var/lib/openshift/f7f2ea44d1f44085a4b8c7409a807971//php-5.3
520      11815  0.0  0.0  32200  1196 ?        S    03:10   0:00 /usr/sbin/rotatelogs /var/lib/openshift/f7f2ea44d1f44085a4b8c7409a807971/php-5.3/logs/e
520      11816  0.0  0.0  32200  1192 ?        S    03:10   0:00 /usr/sbin/rotatelogs /var/lib/openshift/f7f2ea44d1f44085a4b8c7409a807971/php-5.3/logs/a
520      11835  0.0  0.2 363064  7480 ?        S    03:10   0:00 /usr/sbin/httpd -C Include /var/lib/openshift/f7f2ea44d1f44085a4b8c7409a807971//php-5.3
520      12631  0.0  0.0  95772  1812 ?        S    03:12   0:00 sshd: f7f2ea44d1f44085a4b8c7409a807971@pts/0
520      12720  0.0  0.0 108428  2092 ?        Ss   03:12   0:00 /bin/bash --init-file /usr/bin/rhcsh -i
520      13428  1.0  0.0 110228  1168 ?        R+   03:14   0:00 ps -aux

Note You need to log in before you can comment on or make changes to this bug.