Bug 861596 - quorum: servers are not brought back up when quorum is disabled
quorum: servers are not brought back up when quorum is disabled
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: build (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
Sudhir D
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-29 07:45 EDT by Sachidananda Urs
Modified: 2013-09-23 18:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:29:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sachidananda Urs 2012-09-29 07:45:51 EDT
Description of problem:

In a 2x2 setup:

0. Set the qurum ratio to 100.
1. Bring down one of the machine (pulled the power plug in this case).
2. All the glusterfsd processes are down (as expected).
3. Disable server quorum by setting cluster.server-quorum-type to none.

The above step should have brought back the daemons up. But they are still down!
Comment 2 Pranith Kumar K 2012-09-30 02:52:32 EDT
Sac, you lucky man, whenever I tried to execute this case the following bug used to be hit: 847214. Even when I tried to re-create this issue, I hit a manifestation of that bug:

The commit op is never called :-(.
Old State: [Stage op sent]
New State: [Ack drain]
Event    : [GD_OP_EVENT_START_UNLOCK]
timestamp: [2012-09-30 11:11:15]

Old State: [Ack drain]
New State: [Ack drain]
Event    : [GD_OP_EVENT_START_UNLOCK]
timestamp: [2012-09-30 11:11:15]

Old State: [Ack drain]
New State: [Ack drain]
Event    : [GD_OP_EVENT_RCVD_ACC]
timestamp: [2012-09-30 11:11:15]

Old State: [Ack drain]
New State: [Ack drain]
Event    : [GD_OP_EVENT_RCVD_ACC]
timestamp: [2012-09-30 11:11:15]

You seemed to have avoided this race pretty well :-).

I made a partial fix so that I can see if it is that bug but there is still one more bug in my quorum patch. Fixed it and sent the patch.

I have sent the patch for the race for review to glusterd team. I am not sure why the code is like that.
Comment 3 Scott Haines 2013-09-23 18:29:55 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.