This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 861603 - yum can't upgrade if clang is installed
yum can't upgrade if clang is installed
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-29 08:53 EDT by Santiago Saavedra
Modified: 2014-01-21 18:23 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-03 12:39:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Santiago Saavedra 2012-09-29 08:53:59 EDT
Description of problem:
On yum upgrade anything will be upgraded due to an unmet dependency with clang, requiring an obsoleted libstdc++-devel.

Version-Release number of selected component (if applicable):
clang-3.0-13.fc17.x86_64 (current version in @updates)
libstdc++-devel = 4.7.0 (expected by clang)
libstdc++-devel-4.7.2-2.fc17.x86_64 (current version in @updates)

How reproducible:
You will need a working system with libstdc++-devel = 4.7.0.

Steps to Reproduce:
1. # yum install clang
2. # yum install gcc # - Will fail due to newer libstdc++-devel requirement.
  
Actual results:
Yum transaction failed due to newer libstdc++-devel requirement on gcc but not working for clang-3.0-13.

Expected results:
Yum transaction should upgrade also clang with a newer package built for libstdc++-devel-4.7.2.
Comment 1 Santiago Saavedra 2012-10-03 12:39:08 EDT
clang package has been now updated to 3.0-14.fc17.x86_64, which admits libstdc++-devel-4.7.2-2.fc17.x86_64.

Note You need to log in before you can comment on or make changes to this bug.