Bug 861617 - puppet --parseonly broken (ruby 1.9.x issue)
puppet --parseonly broken (ruby 1.9.x issue)
Status: CLOSED DUPLICATE of bug 809911
Product: Fedora
Classification: Fedora
Component: puppet (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-29 10:21 EDT by Matthew Miller
Modified: 2013-03-20 09:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-20 09:28:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2012-09-29 10:21:07 EDT
Description of problem:

See upstream bug http://projects.puppetlabs.com/issues/16445


$  puppet --parseonly 
/usr/share/rubygems/rubygems/custom_require.rb:36:in `require': iconv will be deprecated in the future, use String#encode instead.
Could not parse options: wrong number of arguments (1 for 0)


Version-Release number of selected component (if applicable):

puppet-2.7.18-1.fc17.noarch
ruby-1.9.3.194-16.fc17.x86_64


Upstream has closed the bug as wontfix, as they don't support the version of ruby we have. I understand that puts us in a hard place, but I think we need a solution here.
Comment 1 Todd Zullinger 2013-03-18 11:18:51 EDT
I'm not sure I see a good way out of this.  It's unfortunate that --parseonly was removed upstream and it's unfortunate that 1.9 made it into f17 leaving us with no choice but to update puppet to 2.7 before we wanted to do so.  At this point in f17's life, I'm not sure that it's something that is worth the effort to fix.  3.1 is in f18+ and that should resolve the issue.

Thoughts?
Comment 2 Todd Zullinger 2013-03-20 09:28:00 EDT
Actually, I didn't look closely enough at this.  Using --parseonly is unsupported in 2.7, so that's not something we will support in our packages.  You should use puppet parser validate [<manifest>] [<manifest> ...] instead, as the 2.7 release notes suggest¹.

The iconv warning is going to be fixed with a few backported patches from the 3.x branch upstream.  That is already filed and tracked in bug #809911.  I am closing this as a duplicate of that bug, as the only valid bug here is that warning.

Sorry for the long delay.

¹ http://docs.puppetlabs.com/puppet/2.7/reference/release_notes.html#deprecations

*** This bug has been marked as a duplicate of bug 809911 ***

Note You need to log in before you can comment on or make changes to this bug.