Bug 861795 - [abrt] hplip-3.12.9-1.fc16: setupdialog.py:742:findPrinterPPD:TypeError: getPPDFile2() takes exactly 3 arguments (2 given)
[abrt] hplip-3.12.9-1.fc16: setupdialog.py:742:findPrinterPPD:TypeError: getP...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:892d347928024af647e6eccce0e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-30 16:02 EDT by LandOGil
Modified: 2012-10-01 08:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-01 08:07:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description LandOGil 2012-09-30 16:02:18 EDT
libreport version: 2.0.10
abrt_version:   2.0.7
cmdline:        /usr/bin/python /usr/bin/hp-setup --gui
executable:     /usr/bin/hp-setup
kernel:         3.4.9-2.fc16.i686
time:           Sun 30 Sep 2012 01:32:49 PM MDT
uid:            501
username:       Margo

backtrace:
:setupdialog.py:742:findPrinterPPD:TypeError: getPPDFile2() takes exactly 3 arguments (2 given)
:
:Traceback (most recent call last):
:  File "/usr/share/hplip/ui4/setupdialog.py", line 1245, in NextButton_clicked
:    self.showAddPrinterPage()
:  File "/usr/share/hplip/ui4/setupdialog.py", line 666, in showAddPrinterPage
:    self.findPrinterPPD()
:  File "/usr/share/hplip/ui4/setupdialog.py", line 742, in findPrinterPPD
:    self.print_ppd = cups.getPPDFile2(ppd_name, self.ppds)
:TypeError: getPPDFile2() takes exactly 3 arguments (2 given)
:
:Local variables in innermost frame:
:self: <ui4.setupdialog.SetupDialog object at 0x85cb464>
:ppd_name: 'laserjet_cm1410_series'

smolt_data:
:
:
:General
:=================================
:UUID: f183b704-0bb3-4a9a-b0fa-497286a217e3
:OS: Fedora release 16 (Verne)
:Default run level: 5
:Language: en_US.utf8
:Platform: i686
:BogoMIPS: 2799.77
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Celeron(R) M processor         1.40GHz
:CPU Stepping: 8
:CPU Family: 6
:CPU Model Num: 13
:Number of CPUs: 1
:CPU Speed: 1400
:System Memory: 987
:System Swap: 1983
:Vendor: Unknown
:System:  
:Form factor: Notebook
:Kernel: 3.4.9-2.fc16.i686
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:9415:5508:36896) pci, uhci_hcd, USB, 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3
:(4172:32803:5508:28672) pci, firewire_ohci, FIREWIRE, TSB43AB22A IEEE-1394a-2000 Controller (PHY/Link) [iOHCI-Lynx]
:(4172:44112:5508:12800) pci, yenta_cardbus, PCI/CARDBUS, PCI1410 PC card Cardbus Controller
:(32902:13698:5508:38144) pci, i915, VIDEO, 82852/855GM Integrated Graphics Device
:(32902:13698:5508:38144) pci, None, VIDEO, 82852/855GM Integrated Graphics Device
:(32902:9418:5508:36896) pci, ata_piix, STORAGE, 82801DBM (ICH4-M) IDE Controller
:(32902:9420:0:0) pci, None, PCI/ISA, 82801DBM (ICH4-M) LPC Interface Bridge
:(32902:9414:5508:16391) pci, snd_intel8x0m, SIMPLE, 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller
:(32902:9413:5508:33794) pci, snd_intel8x0, MULTIMEDIA_AUDIO, 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller
:(32902:9411:5508:36896) pci, i801_smbus, SERIAL, 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller
:(32902:9288:0:0) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(4332:33081:5508:38656) pci, 8139too, ETHERNET, RTL-8139/8139C/8139C+
:(32902:9410:5508:36896) pci, uhci_hcd, USB, 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1
:(32902:9412:5508:36896) pci, uhci_hcd, USB, 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2
:(32902:13701:5508:36896) pci, None, BASE, 82852/82855 GM/GME/PM/GMV Processor to I/O Controller
:(32902:13696:5508:36896) pci, agpgart-intel, HOST/PCI, 82852/82855 GM/GME/PM/GMV Processor to I/O Controller
:(32902:13700:5508:36896) pci, None, BASE, 82852/82855 GM/GME/PM/GMV Processor to I/O Controller
:(5772:19:5199:28677) pci, ath5k, ETHERNET, Atheros AR5001X+ Wireless Network Adapter
:(32902:9421:5508:36896) pci, ehci_hcd, USB, 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_conifer-lv_root / ext4 4096 4096 8998818 3932100 3840701 2285568 1927295 1927295
:/dev/sda1 /boot ext4 1024 1024 495844 458826 433226 128016 127776 127776
:
Comment 1 Jiri Popelka 2012-10-01 08:07:01 EDT
Seems that your hplip installation is in some inconsistent state.
The bug summary claims that you use hplip-3.12.9-1.fc16 but the code where the problem occurred was removed in hplip-3.12.9.

If you had previously installed hplip with upstream installer then this could be the cause.
The upstream installer provides a /usr/share/hplip/uninstall script which should remove the upstream installer installed files. If you find this file, run it.

then remove Fedora's packages with:
yum remove 'hplip*'

then install Fedora packages again:
yum install hplip-gui

What do 'rpm -q hplip' and 'rpm -V hplip hplip-common hplip-libs hpijs' show after the reinstallation ?

Note You need to log in before you can comment on or make changes to this bug.