Bug 861896 - Dracut fails to install on FCoE boot
Dracut fails to install on FCoE boot
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Harald Hoyer
Bruno Goncalves
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-01 05:22 EDT by Bruno Goncalves
Modified: 2012-10-02 02:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-02 02:30:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Console log (66.27 KB, text/x-log)
2012-10-01 05:23 EDT, Bruno Goncalves
no flags Details

  None (edit)
Description Bruno Goncalves 2012-10-01 05:22:49 EDT
Description of problem:

udevd[648]: error: can not open '/sys/devices/pci0000:00/0000:00:0b.0/0000:09:00.0/0000:0a:05.0/0000:0c:00.2/firmware/0000:0c:00.2/loading'

Version-Release number of selected component (if applicable):

uname -r
3.3.0-0.20.el7.x86_64

dracut: dracut-018-65.git20120612.el7

How reproducible:
100%

Steps to Reproduce:
1.Trying to install the image on the server, it always exit with:
s/devices/pci0000:00/0000:00:0b.0/0000:09:00.0/0000:0a:05.0/0000:0c:00.3/net/rename6 (4252)
udevd[645]: error changing net interface name rename6 to eth0-renamed: File exists

2.
3.
  
Actual results:
Installation fails

   46.161470] ADDRCONF(NETDEV_CHANGE): eth0-renamed: link becomes ready
[  101.857985] Can't locate firmware ctfw.bin
[  101.883265] Failed to load Firmware Image!
[  101.910215] bnad_pci_probe : (0xffff880813248000, 0xffffffffa03583a0) PCI Func : (3)
[  101.982504] bar0 mapped to ffffc9001ee80000, len 262144
udevd[648]: error: can not open '/sys/devices/pci0000:00/0000:00:0b.0/0000:09:00.0/0000:0a:05.0/0000:0c:00.2/firmware/0000:0c:00.2/loading'

[  102.716615] udevd[645]: renamed network interface eth0 to rename6
[  102.759921] INFO: trying to register non-static key.
[  102.760014] the code is fine but needs lockdep annotation.
[  102.760014] turning off the locking correctness validator.
[  102.760014] Pid: 646, comm: work_for_cpu Not tainted 3.3.0-0.20.el7.x86_64 #1
[  102.760014] Call Trace:
[  102.760014]  [<ffffffff810cee63>] __lock_acquire+0x1363/0x1bb0
[  102.760014]  [<ffffffff810200d9>] ? sched_clock+0x9/0x10
[  102.760014]  [<ffffffff810a5f55>] ? sched_clock_local+0x25/0xa0
[  102.760014]  [<ffffffff810cfd81>] lock_acquire+0xa1/0x1e0
[  102.760014]  [<ffffffffa0463b83>] ? bfa_fcs_lport_aen_post+0x43/0x160 [bfa]
[  102.760014]  [<ffffffff81662f25>] _raw_spin_lock_irqsave+0x65/0xb0
[  102.760014]  [<ffffffffa0463b83>] ? bfa_fcs_lport_aen_post+0x43/0x160 [bfa]
[  102.760014]  [<ffffffffa0463b83>] bfa_fcs_lport_aen_post+0x43/0x160 [bfa]
[  102.760014]  [<ffffffffa0471a57>] bfa_fcs_lport_init+0x97/0x120 [bfa]
[  102.760014]  [<ffffffffa045f4ff>] bfa_fcs_fabric_sm_uninit+0x1cf/0x250 [bfa]
[  102.760014]  [<ffffffffa045e1da>] bfa_fcs_fabric_modinit+0x2a/0xb0 [bfa]
[  102.760014]  [<ffffffffa045def2>] ? bfa_fcs_fabric_attach+0xf2/0x170 [bfa]
[  102.760014]  [<ffffffffa046075a>] bfa_fcs_init+0x2a/0x40 [bfa]
[  102.760014]  [<ffffffffa043ccf7>] bfad_drv_init+0x107/0x1f0 [bfa]
[  102.760014]  [<ffffffffa043d057>] bfad_pci_probe+0x277/0x450 [bfa]
[  102.760014]  [<ffffffff81354b8c>] local_pci_probe+0x5c/0xd0
[  102.760014]  [<ffffffff81083e50>] ? destroy_work_on_stack+0x20/0x20
[  102.760014]  [<ffffffff81083e68>] do_work_for_cpu+0x18/0x30
[  102.760014]  [<ffffffff8108d997>] kthread+0xb7/0xc0
[  102.760014]  [<ffffffff8166cef4>] kernel_thread_helper+0x4/0x10
[  102.760014]  [<ffffffff81663234>] ? retint_restore_args+0x13/0x13
[  102.760014]  [<ffffffff8108d8e0>] ? kthread_worker_fn+0x1a0/0x1a0
[  102.760014]  [<ffffffff8166cef0>] ? gs_change+0x13/0x13


Expected results:
Installation should work.

Additional info:
Comment 1 Bruno Goncalves 2012-10-01 05:23:52 EDT
Created attachment 619706 [details]
Console log
Comment 2 Bruno Goncalves 2012-10-01 05:25:00 EDT
It might be similar to:
https://bugzilla.redhat.com/show_bug.cgi?id=831955
Comment 4 Harald Hoyer 2012-10-01 16:08:07 EDT
(In reply to comment #0)
> Description of problem:
> 
> udevd[648]: error: can not open
> '/sys/devices/pci0000:00/0000:00:0b.0/0000:09:00.0/0000:0a:05.0/0000:0c:00.2/
> firmware/0000:0c:00.2/loading'
> 
> Version-Release number of selected component (if applicable):
> 
> uname -r
> 3.3.0-0.20.el7.x86_64
> 
> dracut: dracut-018-65.git20120612.el7
> 
> How reproducible:
> 100%
> 
> Steps to Reproduce:
> 1.Trying to install the image on the server, it always exit with:
> s/devices/pci0000:00/0000:00:0b.0/0000:09:00.0/0000:0a:05.0/0000:0c:00.3/net/
> rename6 (4252)
> udevd[645]: error changing net interface name rename6 to eth0-renamed: File
> exists

What exactly was the kernel cmdline here? Where does it fail? After installation on the first reboot?


> [  101.857985] Can't locate firmware ctfw.bin
> [  101.883265] Failed to load Firmware Image!

Does ctfw.bin exist anywhere in our distribution?

# find  /lib/firmware/ -name ctfw.bin




> [  102.760014] Pid: 646, comm: work_for_cpu Not tainted
> 3.3.0-0.20.el7.x86_64 #1
> [  102.760014] Call Trace:
> [  102.760014]  [<ffffffff810cee63>] __lock_acquire+0x1363/0x1bb0
> [  102.760014]  [<ffffffff810200d9>] ? sched_clock+0x9/0x10
> [  102.760014]  [<ffffffff810a5f55>] ? sched_clock_local+0x25/0xa0
> [  102.760014]  [<ffffffff810cfd81>] lock_acquire+0xa1/0x1e0
> [  102.760014]  [<ffffffffa0463b83>] ? bfa_fcs_lport_aen_post+0x43/0x160
> [bfa]
> [  102.760014]  [<ffffffff81662f25>] _raw_spin_lock_irqsave+0x65/0xb0
> [  102.760014]  [<ffffffffa0463b83>] ? bfa_fcs_lport_aen_post+0x43/0x160
> [bfa]
> [  102.760014]  [<ffffffffa0463b83>] bfa_fcs_lport_aen_post+0x43/0x160 [bfa]
> [  102.760014]  [<ffffffffa0471a57>] bfa_fcs_lport_init+0x97/0x120 [bfa]
> [  102.760014]  [<ffffffffa045f4ff>] bfa_fcs_fabric_sm_uninit+0x1cf/0x250
> [bfa]
> [  102.760014]  [<ffffffffa045e1da>] bfa_fcs_fabric_modinit+0x2a/0xb0 [bfa]
> [  102.760014]  [<ffffffffa045def2>] ? bfa_fcs_fabric_attach+0xf2/0x170 [bfa]
> [  102.760014]  [<ffffffffa046075a>] bfa_fcs_init+0x2a/0x40 [bfa]
> [  102.760014]  [<ffffffffa043ccf7>] bfad_drv_init+0x107/0x1f0 [bfa]
> [  102.760014]  [<ffffffffa043d057>] bfad_pci_probe+0x277/0x450 [bfa]
> [  102.760014]  [<ffffffff81354b8c>] local_pci_probe+0x5c/0xd0
> [  102.760014]  [<ffffffff81083e50>] ? destroy_work_on_stack+0x20/0x20
> [  102.760014]  [<ffffffff81083e68>] do_work_for_cpu+0x18/0x30
> [  102.760014]  [<ffffffff8108d997>] kthread+0xb7/0xc0
> [  102.760014]  [<ffffffff8166cef4>] kernel_thread_helper+0x4/0x10
> [  102.760014]  [<ffffffff81663234>] ? retint_restore_args+0x13/0x13
> [  102.760014]  [<ffffffff8108d8e0>] ? kthread_worker_fn+0x1a0/0x1a0
> [  102.760014]  [<ffffffff8166cef0>] ? gs_change+0x13/0x13

This looks like a driver failure in the kernel.
Comment 5 Bruno Goncalves 2012-10-02 02:30:30 EDT
Sorry, it is not a bug. 
I was using the wrong ksdevice during installation.

Note You need to log in before you can comment on or make changes to this bug.