Bug 861925 - glustershd logs too much in client3_1_unlink_cbk.
glustershd logs too much in client3_1_unlink_cbk.
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.0
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: vsomyaju
Vijaykumar Koppad
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-01 07:28 EDT by Vijaykumar Koppad
Modified: 2015-03-04 19:06 EST (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0qa5, glusterfs-3.3.0.5.rhs-40
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:39:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaykumar Koppad 2012-10-01 07:28:39 EDT
Description of problem: If you do lot of create and delete operations, glustershd log file fill up too much of the size 20 to 30 GB in a week time frame. 

sample logs , 

[2012-09-23 03:50:04.732260] W [client3_1-fops.c:592:client3_1_unlink_cbk] 0-master-client-3: remote operation failed: No such file or directory
[2012-09-23 03:50:04.734911] W [client3_1-fops.c:592:client3_1_unlink_cbk] 0-master-client-3: remote operation failed: No such file or directory
[2012-09-23 03:50:04.735745] W [client3_1-fops.c:592:client3_1_unlink_cbk] 0-master-client-3: remote operation failed: No such file or directory
[2012-09-23 03:50:04.736636] W [client3_1-fops.c:592:client3_1_unlink_cbk] 0-master-client-3: remote operation failed: No such file or directory



Version-Release number of selected component (if applicable):3.3.0rhs-28.el6rhs.x86_64


How reproducible: Deterministically


Steps to Reproduce:
1.Run lot create and remove of files operation on the mount point distributed-replicate volume 
2.Do some brick up and down operation too
3.Logs will go up . 
  
Actual results: The logs fill up too much 


Expected results: It shouldn't log so much 


Additional info:
Comment 2 Vijay Bellur 2012-10-12 12:18:55 EDT
CHANGE: http://review.gluster.org/4069 (protocol/client: Conditional logging in client3_3_unlink_cbk) merged in master by Anand Avati (avati@redhat.com)
Comment 3 Scott Haines 2013-09-23 18:39:15 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 4 Scott Haines 2013-09-23 18:43:42 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.