Bug 861940 - error selecting install target: "no disks selected"/"error checking storage configuration"
error selecting install target: "no disks selected"/"error checking storage c...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-01 08:13 EDT by pi_raph
Modified: 2012-11-28 14:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-28 14:00:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
program.log with auto partitioning (68.13 KB, text/x-log)
2012-10-01 08:13 EDT, pi_raph
no flags Details
anaconda.log with auto partitioning (2.80 KB, text/plain)
2012-10-01 08:14 EDT, pi_raph
no flags Details
storage.log with auto (195.44 KB, text/plain)
2012-10-01 08:15 EDT, pi_raph
no flags Details
program.log with manual partitioning (91.04 KB, text/plain)
2012-10-01 08:15 EDT, pi_raph
no flags Details
anaconda.log with manual partitioning (5.62 KB, text/plain)
2012-10-01 08:16 EDT, pi_raph
no flags Details
storage.log with manual partitioning (298.96 KB, text/plain)
2012-10-01 08:16 EDT, pi_raph
no flags Details

  None (edit)
Description pi_raph 2012-10-01 08:13:08 EDT
Created attachment 619759 [details]
program.log with auto partitioning

Description of problem:

The Fedora 18 Alpha LiveCD installer keeps complaining "no disks selected" even after selecting a disk and choosing automatic partitioning. When trying custom partitioning the error message changes to "error checking storage configuration"


Version-Release number of selected component (if applicable):
Fedora-18-Alpha-i686-Live-XFCE.iso


How reproducible:
Always


Steps to Reproduce:
1. boot livecd
2. install to hd
3. proceed to disk selection.
4. choose disk and use automatic partitioning
5. return to overview screen
  
Actual results:

Error message "no disks selected" or "error checking storage configuration"

Expected results:
Being able to proceed with installation

Additional info:

that might be the cause for both cases (from program.log)
 ERR program: FATAL: Module scsi_wait_scan not found.
Comment 1 pi_raph 2012-10-01 08:14:56 EDT
Created attachment 619761 [details]
anaconda.log with auto partitioning
Comment 2 pi_raph 2012-10-01 08:15:21 EDT
Created attachment 619762 [details]
storage.log with auto
Comment 3 pi_raph 2012-10-01 08:15:50 EDT
Created attachment 619763 [details]
program.log with manual partitioning
Comment 4 pi_raph 2012-10-01 08:16:12 EDT
Created attachment 619764 [details]
anaconda.log with manual partitioning
Comment 5 pi_raph 2012-10-01 08:16:37 EDT
Created attachment 619765 [details]
storage.log with manual partitioning
Comment 6 Jesse Keating 2012-10-01 12:52:54 EDT
So it looks like your live USB is showing up as /dev/sda, and for whatever reason we don't look at / find /dev/sdb as a valid stage1 device for the boot loader, thus you fail the storage checks.

Passing on to our storage point of contact.
Comment 7 Paul Maunders 2012-10-25 14:25:35 EDT
I'm also seeing a similar problem when attempting to do a network install using virt-install and a remote kickstart.

Steps to reproduce... 

1) Run this virt-install command....

    virt-install \
    --name "fedora18-alpha-guest" \
    --ram 1024 \
    --nographics \
    --os-type=linux \
    --os-variant=rhel6 \
    --location=http://mirror.ox.ac.uk/sites/download.fedora.redhat.com/pub/fedora/linux/releases/test/18-Alpha/Fedora/x86_64/os/ \
    --extra-args="ks=http://fubralimited.github.com/CentOS-KVM-Image-Tools/kickstarts/fedora18-alpha-guest-gpt.cfg text console=tty0 utf8 console=ttyS0,115200" \
    --disk path=/var/lib/libvirt/images/fedora18-alpha-guest.img,size=10,bus=virtio,format=qcow2

2) Watch the console, and look out for errors in storage.log and program.log

Storage.log - 

INFO anaconda: No FCoE EDD info found: No FCoE boot disk information is found in EDD!

Program.log - 

ERR program: FATAL: Module scsi_wait_scan not found.

The installer hangs at this step.

Regards,

Paul
Comment 8 Paul Maunders 2012-10-25 14:28:09 EDT
There are also lots of the following error in /tmp/syslog:

ERR systemd-udevd: failed to execute '/usr/lib/udev/socket:/org/kernel/dm/multipath_event' 'socket:/org/kernel/dm/multipath_event': No such file or directory
Comment 9 David Lehman 2012-10-25 16:16:26 EDT
(In reply to comment #7)
> I'm also seeing a similar problem when attempting to do a network install
> using virt-install and a remote kickstart.

This sounds like a different issue, even if only because you're doing kickstart as opposed to a live install. Please open a new bug and include the following log files from /tmp as attachments of type text/plain:

 anaconda.log
 program.log
 storage.log
 packaging.log
 syslog

Thanks.
Comment 10 Paul Maunders 2012-10-26 07:18:03 EDT
OK new bug submitted here: https://bugzilla.redhat.com/show_bug.cgi?id=870388
Comment 11 pi_raph 2012-11-28 14:00:22 EST
same system with Fedora-18-Beta-i686-Live-XFCE.iso does not have that problem anymore. Thanks.

Note You need to log in before you can comment on or make changes to this bug.